locked
Getting Error on IIS after publishing orchestration as Service. RRS feed

  • Question

  • Hi Experts.

    I have published my Orchestration As Service.And after that when I try to run from IIS it is giving the below error.

    Login failed for user 'IIS APPPOOL\DefaultAppPool'.

    System.Data.SqlClient.SqlException: Login failed for user 'IIS APPPOOL\DefaultAppPool'.
    After some googling also I am not able to solve this.

    Can experts please tell me how to fix this.

    Thanks

    Tuesday, April 16, 2013 4:14 AM

Answers

  • There are few things that need to be done.

    1. Create a Virtual Directory (which you;ve done)
    2. Create an Application Pool (which you;ve done)
    3. Associate a Pool Identity which is a menber of IIS_WPG, BizTalk Isolated Host users (which you;ve done)
    4. Ensure you have a BizTalk Isolated Host defined with the same credentials.
    5. Ensure you have an Host Instance of the above host.
    6. Ensure that the wcf-basicHTTP receive handler has a receive handler associated with this host.
    7. Publish your orchestration into the Virtual Directory/Application (if you;ve not created a receive location, ask for one to be created during the publishing).
    8. Bind your orchestration to the created receive location

    Regards.

    Tuesday, April 16, 2013 7:40 AM

All replies

  • You need to change the identity of the application pool in IIS used for virtual directory or you can create new application pool but make sure that this user is member of BizTalk Isolated Host Users group.

    Please mark the post answered your question as answer, and mark other helpful posts as helpful, it'll help other users who are visiting your thread for the similar problem, Regards -Rohit Sharma (http://rohitt-sharma.blogspot.com/)

    Tuesday, April 16, 2013 4:34 AM
    Moderator
  • You are getting the error because the account/identity associated with the DefaultAppPool is not a member of the BizTalk Isolated Host Users group. During installation, this group is provided the required access to the BizTalk databases.

    You need to change the identity of the published application in IIS to that of the isoloated host handler account associated with the receive location in your BizTalk application.

    Regards.

    Tuesday, April 16, 2013 4:35 AM
  • Thanks experts ,

    But can you please brief it how I will do that.

    Thanks


    • Edited by Ashis_K Tuesday, April 16, 2013 4:48 AM
    • Proposed as answer by Ali Hyder Tuesday, December 24, 2013 1:36 PM
    Tuesday, April 16, 2013 4:45 AM
  • Hi Experts,

    I tried to change the Identity but not able to do that.

    Can you please explained how to change the Identity wrt Service.

    Thanks

    • Proposed as answer by Ali Hyder Thursday, September 12, 2013 1:09 PM
    Tuesday, April 16, 2013 5:05 AM
  • Look at "Create an Application Pool" @http://technet.microsoft.com/en-us/library/cc731784(v=ws.10).aspx and look at "Specify an Identity for the Application Pool" @http://technet.microsoft.com/en-us/library/cc771170(v=ws.10).aspx

    So create a new application pool to host your BizTalk Applications, assign the BizTalk Isolated Host service account as the identity and use this application pool for your published application @http://technet.microsoft.com/en-us/library/cc731755(v=ws.10).aspx

    Regards.

    Tuesday, April 16, 2013 5:16 AM
  • Hi Experts,

    I created

    New Application pool,Add Identity as a my created user which holds all the necessary groups like BizTalk Isolate host,IUSR and finally changed the Application pool to created poo;.

    But still getting follwing error

    The Messaging Engine failed to register the adapter for "WCF-BasicHttp" for the receive location ".svc". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    Can you please clarify this.

    Thanks. 

    Tuesday, April 16, 2013 5:58 AM
  • There are few things that need to be done.

    1. Create a Virtual Directory (which you;ve done)
    2. Create an Application Pool (which you;ve done)
    3. Associate a Pool Identity which is a menber of IIS_WPG, BizTalk Isolated Host users (which you;ve done)
    4. Ensure you have a BizTalk Isolated Host defined with the same credentials.
    5. Ensure you have an Host Instance of the above host.
    6. Ensure that the wcf-basicHTTP receive handler has a receive handler associated with this host.
    7. Publish your orchestration into the Virtual Directory/Application (if you;ve not created a receive location, ask for one to be created during the publishing).
    8. Bind your orchestration to the created receive location

    Regards.

    Tuesday, April 16, 2013 7:40 AM
  • Hi,

    Also make sure your receive location is enabled.

    Regards,

    Rahul Madaan

    BizTalkVillage.blogspot.com

    Tuesday, April 16, 2013 10:04 AM