locked
Windows 8.1 search database abnormal size ~100Gb RRS feed

  • Question

  • C:\ProgramData\Microsoft\Search\Data\Applications\Windows\Windows.edb is nearly 100Gb, which is too much on a SanDisk SSD with a total size of 240GB and it keeps on growing...

    Am I right in thinking that this is abnormal? I've tried deleting that file but in about two weeks it grows again. I understand that a similar bug was fixed for a previous windows version and that it should not be present in 8.1!? Any idea what I can do?

    Tuesday, June 17, 2014 6:30 PM

Answers

  • By the way, for some immediate relief, try this:

    • Pop up your Start screen and type the words:  indexing options and hit Enter. 
       
    • The Indexing Options dialog should come up on the desktop.
       
    • Press the [Advanced] button.
       
    • Click the [Rebuild] button.
       

    This may resolve your index oversize issue for now.  There's also a troubleshooting link in there.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options


    • Edited by Noel Carboni Tuesday, June 17, 2014 7:01 PM fixed a formatting problem
    • Marked as answer by Michael_LS Wednesday, July 2, 2014 2:29 AM
    Tuesday, June 17, 2014 6:59 PM

All replies

  • It's not unreasonable to consider just disabling indexing.  Searches will still work fine, especially with an SSD giving you very fast data access.

    Indexing is a rather poor implementation of a questionable idea.  That's a lot of years computer engineering experience talking.

    I've personally run all my systems without Indexing since Win 7 came out, and I've not found anything I cannot do.  They're even pretty fast (I too use SSD).  Not only does it not hurt anything, but it actually increases the chances of finding things that are really there, as corrupted indexes cannot be a problem.

    That said, while I use Win 8.1 now on my systems I absolutely do not use any of the Metro/Modern side of it, so I don't know if there are things there that might rely on Indexing.  I hope not, because it doesn't work very well (as you have seen), but I just don't know.

    I'll be happy to list the specific configuration changes needed to disable indexing and still retain the ability to search if you'd like to experiment yourself.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Tuesday, June 17, 2014 6:53 PM
  • By the way, for some immediate relief, try this:

    • Pop up your Start screen and type the words:  indexing options and hit Enter. 
       
    • The Indexing Options dialog should come up on the desktop.
       
    • Press the [Advanced] button.
       
    • Click the [Rebuild] button.
       

    This may resolve your index oversize issue for now.  There's also a troubleshooting link in there.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options


    • Edited by Noel Carboni Tuesday, June 17, 2014 7:01 PM fixed a formatting problem
    • Marked as answer by Michael_LS Wednesday, July 2, 2014 2:29 AM
    Tuesday, June 17, 2014 6:59 PM