none
DPM 2010 and ArcVault Tape Library Problem

    Question

  • We have DPM 2010 installed on a Windows 2008 R2 64-bit server, attached is a Overland ArcVault 12 slot changer with HP LTO4 drive.

    The changer was previously connected to a CommVault backup server and worked with no problems, but now it is attached to DPM I can't get any tape backups to work.

    I can see the changer in DPM and it has the tape drive listed and I can see all 12 slots and the tape barcodes of each tape currently loaded. 

    However, I am unable to erase tapes or run an inventory or any backups.  The usual error is

    Affected area:  (ADO199L4)
    Occurred since: 14/02/2011 12:20:16 PM
    Description: The detailed inventory of tape failed for the following reason: (ID 3316)
     DPM encountered a critical error while performing an I/O operation on the tape  (ADO199L4) (Barcode - ADO199L4) in Drive Hewlett Packard LTO Ultrium-4 drive. (ID 30101 Details: The I/O bus was reset (0x80070457))

    Or similar with a (0x007045D) error.

    Having read around this issue it seems likely to be a driver issue, but I am unable to find updated 64-bit drivers for Windows 2008.

    In device manager the ArcVault is listed under Medium Changer devices as 'Overland NEO Series Medium Changers' and under Tape drives we have 'Hewlett Packard LTO Ultrium-4 drive'. 

    The drivers used are

    Library - HP driver neomslmc.sys 3.0.2.0

    Tpae Drive - HP driver hplto.sys 1.0.6.3

    I have tried other drivers, but these are the only ones I have found so far which shows the tape drive and library (and not the tape drive as a stand alone device).

    Can anyone point me in the direction of drivers that may resolve this problem.

    Thanks

    Mark 

    • Moved by MarcReynolds Monday, February 14, 2011 1:27 PM (From:Data Protection Manager)
    Monday, February 14, 2011 12:35 PM

Answers

All replies

  • Hi

    I ran into a similar I/O problem with an HP Medium Changer. The error was solved be changing the SCSI cable.....

    In your case when your using a Overland media changer I know that it was supported in DPM 2007 but I never got the Overland ArcVault to work with DPM2010. By using a HP autoloader 1/8 instead it worked right away. I think Overland hasn't a good supported driver.

     

    Best Regards

    Robert Hedblom

    MVP DPM



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, February 14, 2011 1:53 PM
    Moderator
  • Hi,

    I don't see that library being supported on Windows 2008 R2 on the Windows Server catalog: http://www.windowsservercatalog.com/  and to get it working on Windows 2003 X64 with DPM 2007, you needed to get special drivers from Overland.

    However, Since it's a HP drive, try the below solution, I've seen it fix similar errors before.

    http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=254838&prodTypeId=12169&prodSeriesId=254838&objectID=c01655150

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\SCSI\<DEVICEID>\<INSTANCE>\DeviceParameters\Storport\
    Value - BusyRetryCount
    Type - DWORD
    Data - 20 Decimal (default) <---- Change to 250dec (0XFA)

     

    You can also try using the Windows Inbox driver (ltotape.sys) for the tape drive.


    1) Open device manager
    2) Locate the tape drive
    3) Right-click and look at the properties.
    3) Under the DRIVER tab, select UPDATE DRIVER
     a) Select the Install from list or specific location (Advanvced) - next.
     b) Select Don't search. I will choose the driver to install. - next.
     c) Uncheck the Show comtabile hardware checkbox.
     d) Highlight LTO under the manufacturer.
     e) Highlight the LTO tape drive under model - then next.
     f) This should install the Microsoft ltotape.sys driver.
    4) Rescan the tape library in the DPM console  - try to take another backup.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, February 14, 2011 8:09 PM
    Moderator
  • Hi Mark.

    I had the exact same problem. I managed to resolve by doing the following:

    Contacted Overland to try and obtain a driver, they refered me to the following HP Link

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3741023&prodTypeId=12169&prodSeriesId=4150338&swLang=8&taskId=135&swEnvOID=4064

    Download the above driver, uninstall both the Tape & the Medium Changer Drivers in the OS.

    Install the Above Driver.

    Your Tape Device should read : Hewlett Packard LTO Ultrium-4 drive

    Your Medium Changer should read : Hewlett Packard MSL G3 Series Library (x64 based)

    Looks like overland took the above insides from HP and branded it into a Overland Box, everything seems to work, lock unlock, label scans etc etc.

     

    Hope this helps (if it does please mark as answer)

    Wednesday, March 2, 2011 8:56 AM
  • Hi krokebob,

    Thanks for the info, looks promising.  Device manager is showing the tape drive and changer as you have shown above but DPM still shows the changer as an 'Overland NEO Series Medium Changer' even after a rescan.  Is this correct?

    Thanks

    Mark

    Thursday, March 3, 2011 4:08 PM
  • Hi thehumph

     

    I had the same issues you described and I found this forum and last night I followed the instructions on the link that Mike provided above to the HP website(http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=254838&prodTypeId=12169&prodSeriesId=254838&objectID=c01655150)  and it fixed my issue.  we've been fighting this for about 3 months and this is the first time we've been able to get this working for this long.  it still yet has about another 8 hours to  finish but its been running since about 11PM last night.  So far so good!  When we began having these issues we ran test after test and found that the SCSI cables were causing errors, we swapped everything out for new cables and terminators and it cut down on a lot of errors. However we still would get the random backup failures.  I’m just mentioning this so no stone is left un-turned in your situation.   

    Thehumph, Good luck 

    Mike thank you!!!!!

     

    -Tony

    Thursday, March 3, 2011 5:07 PM
  • Hi Thehumph.

    No this is not right (if I compare to mine). Maybe go into Device Manager & completely remove by rolling back drivers on the device till you can't anymore & then uninstall the Driver. Make sure then that DPM does not show any devices under Tape Library (you may have to modify any protection groups that's refering to the Tape Library under long term protection)

    Reboot & Re-Install the driver. It should show now, in both DPM & Device Manager as:

    Hewlett Packard MSL G3 Series Library (x64 based) - for the Library

    Hewlett Packard LTO Ultrium-4 drive - For the Drive

     

    Hope this helps (if It works, please mark as answer, I'm desperate for another star!!)

     

     

     

    Monday, March 14, 2011 12:23 PM
  • Hi Krokebob,

    Thanks for the further information, I still can't get DPM to display as the HP MSL G3 even though device manager does.  I'll keep playing with the drivers and see where I can get to.

    I'll leave this open for a little longer in case anyone else comes up with anything, otherwise I'll close and award you the Answer as I think you have set me on the right track.

    Thanks

    Mark

    Wednesday, March 23, 2011 10:19 AM