none
Task Scheduler is not run after "system startup" RRS feed

  • Question

  • I create a task in task scheduler for run every 30 minute on daily basis but after system startup my task is not continue. This is happen on both windows server or normal windows like 7 or 10

    <?xml version="1.0" encoding="UTF-16"?>
    <Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
      <RegistrationInfo>
        <Date>2017-10-10T18:09:08.647231</Date>
        <Author>TS\adnan.ahmed</Author>
      </RegistrationInfo>
      <Triggers>
        <CalendarTrigger>
          <Repetition>
            <Interval>PT30M</Interval>
            <Duration>P1D</Duration>
            <StopAtDurationEnd>false</StopAtDurationEnd>
          </Repetition>
          <StartBoundary>2017-10-10T18:08:12</StartBoundary>
          <Enabled>true</Enabled>
          <ScheduleByDay>
            <DaysInterval>1</DaysInterval>
          </ScheduleByDay>
        </CalendarTrigger>
      </Triggers>
      <Principals>
        <Principal id="Author">
          <GroupId>S-1-5-32-545</GroupId>
          <RunLevel>LeastPrivilege</RunLevel>
        </Principal>
      </Principals>
      <Settings>
        <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
        <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
        <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
        <AllowHardTerminate>true</AllowHardTerminate>
        <StartWhenAvailable>true</StartWhenAvailable>
        <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
        <IdleSettings>
          <StopOnIdleEnd>true</StopOnIdleEnd>
          <RestartOnIdle>false</RestartOnIdle>
        </IdleSettings>
        <AllowStartOnDemand>true</AllowStartOnDemand>
        <Enabled>true</Enabled>
        <Hidden>false</Hidden>
        <RunOnlyIfIdle>false</RunOnlyIfIdle>
        <WakeToRun>false</WakeToRun>
        <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
        <Priority>7</Priority>
        <RestartOnFailure>
          <Interval>PT1M</Interval>
          <Count>3</Count>
        </RestartOnFailure>
      </Settings>
      <Actions Context="Author">
        <Exec>
          <Command>powershell</Command>
          <Arguments>-command &amp;{Invoke-WebRequest http://192.168.1.12:8079/TSAPI/Job/Run}</Arguments>
        </Exec>
      </Actions>
    </Task>


    Saturday, October 21, 2017 5:16 AM

All replies

  • On the General tab make sure you choose the "Run whether user is logged on or not" option. 

    Saturday, October 21, 2017 7:37 AM
  • See the log tab.

    Maybe have you an error about a account named "NONE".

    So, in the General tab don't save the password.  

    This will create the user (You must type the password before to close the task).

    Smells like Windows 95 tricks... souvenirs souvenirs

    Friday, July 12, 2019 9:58 AM