Can't rename a folder in Windows 7 - receive error message RRS feed

  • Question

  • When trying to rename a folder in Windows 7, I get a "Folder In Use" message saying that the folder or a file in it is open in another program.  This is untrue as I don't have any other programs open.  I even rebooted the computer and tried again and it gave me the same message.  This has occurred more than once and it's beginning to drive me crazy.  Do you have any suggestions as to how to fix this problem?
    Tuesday, June 12, 2012 7:02 PM


All replies

  • Use Process Explorer (monitor) from  Sysinternals in your forensics.



    Tuesday, June 12, 2012 8:14 PM
  • Hi,

    Please use the Process Explorer to check which process keeps your file in use.

    In addition, you can try to rename the folder in Safe Mode to see the result.

    For more reference, Troubleshooting with Process Monitor

    Hope this helps

    Vincent Wang

    TechNet Community Support

    • Marked as answer by Leo Huang Wednesday, June 27, 2012 9:31 AM
    Thursday, June 14, 2012 9:11 AM
  • I think this is an unacceptable answer. It's a very, very common problem with Windows 7 that needs another and more simple solution.
    Sunday, July 8, 2012 10:15 PM
  • It is most likely cause by the preview pane creating a temp file so it is technically still open. In the control panel go to folder options and in view menu, disable "show preview handlers in preview pane". Then in the folder make sure to turn off the preview pane in the upper right hand corner.
    • Edited by corber22 Tuesday, November 20, 2012 5:40 PM
    • Proposed as answer by Muddly Sunday, September 29, 2013 1:03 AM
    Tuesday, November 20, 2012 5:39 PM
  • I can see some valid info below... I had the same problem... Process Explorer is a good place to start as stated below...

    For me... I ran powershell in as the Local Administrator and typed the following command

    get-process | more

    The "more" pipe will let you scroll through the information a page at a time... what do you know 1st page i found the problem...

    Look for the CPU values (obviously the higher the value the more chance you have of finding the process locking up the file)

    Bear in mind that the explorer process is running and will have a significant amount of CPU usage as this is the process you are using to do things here so to speak...

    Hope this is helpful to anyone having these problems

    Wednesday, June 5, 2013 1:19 PM
  • I too have the same problem, a lot!! Why can't MS FIX THIS????
    Thursday, September 5, 2013 10:14 PM
  • NO, preview pane not open - I STILL have this problem!!! So annoying!
    Thursday, September 5, 2013 10:16 PM
  • I'm not comfortable with trying this.
    Thursday, September 5, 2013 10:17 PM
  • I'm not comfortable with troubleshooting with process monitor. WHY CAN'T Microsoft fix this problem??? Isn't that what you do there?
    Thursday, September 5, 2013 10:18 PM
  • corber22 thank you! I was having the same issue, and after reading your answer, I found that it was the preview pane causing the problem. Now when I rename a folder I make sure it isn't showing in the preview pane and it works every time!!
    Sunday, September 29, 2013 1:02 AM
  • Thank you!!!!
    Monday, November 18, 2013 4:38 PM
  • For me the problem is always acrotray.exe from Adobe Acrobat. I kill the process and the problem goes away. I guess this has never happened to anyone else. (sarcasm).
    • Proposed as answer by imaginaarius Wednesday, February 25, 2015 8:40 AM
    • Unproposed as answer by imaginaarius Wednesday, February 25, 2015 9:01 AM
    Tuesday, December 24, 2013 9:45 PM
  • You got it man. I click in top right corner to not display the preview and i was able to rename and delete folder thanks alot
    Thursday, January 23, 2014 11:02 PM
  • Long path tool can be helpful on this situation. Thanks
    Thursday, February 13, 2014 9:57 AM
  • It is irritating to get this nonsensical message.  If the folder cannot be renamed because it is supposedly open in another program then why is RENAME an option in the drop-down menu?
    Monday, July 14, 2014 3:45 PM
  • I've tried Process Explorer and Process Monitor, but can't understand what processes are connected to this folder. Why should a person have to be a networking or IT specialist to rename, delete, or transfer a file? It's crazy! I tried safe mode, but since the folder is in a shared drive it would not open that way (I tried safe mode in networking, but it wouldn't let me change it -- I receive the same error). I know that no one else on the network has this folder or any of its files open. All I can tell is the folder is associated with explorer.exe, but if I try to stop that process the whole thing shuts down on me and everything disappears. I've also turned off preview panes as suggested, and that worked for a few of the folders I was trying to rename, but there are still a handful more that won't work.
    Tuesday, September 16, 2014 4:59 PM
  • If you're trying to rename a file/folder under the libraries or shortcuts, MS doesn't handle this well. For example, "Libraries\Videos" - go to the actual path (e.g. C:\Users\JohnSmith\Videos) where these are stored, and you can change the name.
    Monday, September 22, 2014 3:49 PM
  • Didn't work for me :(  This is by far THE most annoying Windows 7 bug for me.
    Wednesday, September 24, 2014 11:03 PM
  • This bug makes me crazy!  I've tried disabling thumbnails, the preview pane, right clicking and "copying" something else, waiting for a while why the "Try Again" window is open, deleting acrotray in Processes, closing any programs that could possibly access the folder.. 

    Sure maybe it'll work in an hour or something.. but who wants to work that way?!?!

    Renaming folders is such a common thing to do - this bug needs to be fixed. 

    Wednesday, September 24, 2014 11:06 PM
  • Hi

    Have a look at this Microsoft KB article 2025703 at support.microsoft.com/kb/2025703

    I had the problem and the suggested fix worked for me.

    Wednesday, October 22, 2014 2:57 PM
  • I had a similar problem though none of those solutions worked. It was very frustrating. I did have luck though with a 3rd party unlocker. I used lockhunter because when I scanned it it didn't have any viruses (that could be detected). Turns out Windows Media Player was keeping it from being renamed. Hope this helps, I just spent the last hour trying to figure out a solution. I agree microsoft should fix this error.

    Also I don't have an enterprise version of windows 7 so I couldn't use the above solution.
    Tuesday, November 4, 2014 9:25 PM
  • i just solved the same issue at my office. for us the problem was due to the presence of pdf files in the folders. we don't use adobe for pdfs, we use bluebeam; a process called BBPrint had to be disabled in order to rename the folders.

    i'd imagine if you use adobe and are having the same issue and you notice that there are pdfs in the folder you're trying to rename you might killing any adobe processes you have running.

    Wednesday, December 10, 2014 10:25 PM
  • This happened to me today. All what I have done to solve this stupid bug is to click and unclick the button "Show the preview pane." button. Now I can rename the folder.

    Hope this helps. Cheers.

    Friday, March 20, 2015 9:35 AM
  • This topic was posted in 2012. It is now almost THREE YEARS and god knows how many versions of Windows later and this is STILL a bug that is causing people to tear their hair out. Why is this still happening? I should not have to have programming knowledge to rename a G-D folder. This is ridiculous. 
    Monday, May 4, 2015 5:51 AM
  • It's really unfortunate that this bug is still appearing.

    With my circumstance, it was indeed a thumbs.db file within the folder and I was able to fix it easily by:

    1. open task manager (right-click on startbar)
    2. end process explorer.exe (this will close your file system windows and startbar)
    3. in task manager window, click File -> New Task
    4. type in explorer.exe
    5. quickly navigate to folder and rename it before it gets locked again...

    Hope this helps someone who can't resolve with other proposed methods.

    • Proposed as answer by PieLam Friday, April 13, 2018 4:48 PM
    Monday, May 11, 2015 2:00 PM
  • Thank you for this. This worked for me. Having to race against the clock to rename a folder is completely ridiculous though.
    Tuesday, May 12, 2015 1:12 AM
  • What I found this evening is that after copying a number of image files from a USB device to a folder on the hard drive, the destination folder is locked until the USB device is removed.

    My simple fix in this instance was to remove the USB device.

    However, I still find that Adobe Acrobat is notoriously poor at releasing files & folders and I often have to shut down Acrobat before I can delete/rename files/folders.

    Wednesday, September 23, 2015 4:42 AM
  • I know this thread is old, but I ran across it in my search for answers.

    The only other program running was Chrome. When I closed Chrome, I could rename my folder.

    Is Chrome snooping at what I'm working on?  Another question to search...

    Monday, February 8, 2016 8:08 PM
  • I know this thread is old, but I ran across it in my search for answers.

    The only other program running was Chrome. When I closed Chrome, I could rename my folder.

    Is Chrome snooping at what I'm working on?  Another question to search...

    Not Chrome for me unfortunately and other fixes (Preview pane, Article 2025703 ,WMP, etc) don't seem to work either, nor restarting Explorer which I thought might have worked, not even closing my other networked PC which had been working on the folder I was trying to rename. Very annoying.
    Saturday, March 26, 2016 11:29 AM
  • Actually, in my case even after reloading Windows 7 I was getting the error but I did a delete on the thumbs.db file that was sitting in the folder I wanted to rename, which it then re-created and actually released the folder for renaming. Hallelujah!
    Monday, March 28, 2016 3:13 PM
  • It is most likely cause by the preview pane creating a temp file so it is technically still open. In the control panel go to folder options and in view menu, disable "show preview handlers in preview pane". Then in the folder make sure to turn off the preview pane in the upper right hand corner.

    Worked for me! Thanks....
    Sunday, May 15, 2016 9:42 PM
  • Hi

    Have a look at this Microsoft KB article 2025703 at support.microsoft.com/kb/2025703

    I had the problem and the suggested fix worked for me.

    It worked for me. Thanks !!!

    Monday, May 30, 2016 11:24 AM
  • With me, the fix was setting the local admin group of the file server as owner of the directory. Problem was instantly solved.
    Monday, July 4, 2016 3:27 PM
  • This is the best and easiest solution.


    Monday, August 8, 2016 4:16 PM
  • Just found a solution to this which ended up being pretty simple (embarrassingly) however my issue may be slightly different but here it is in case it helps anyone!

    User was complaining she couldn't rename a network folder as it kept saying it was open somewhere else, the user was adamant there was nothing open within that folder.

    I logged into the file server and went to start,run, typed MMC.

    then go to file and click on add/remove snap in, add the console root with shared folders (local) and click OK.

    This then displayed a list of files that were currently open and low and behold there were 4 files open that was in that file path! all open by said user!!

    Not 100% but maybe she closed the documents and for whatever reason the server didn't replicate the changes. 

    Any way I simply right clicked and closed the files and was able to rename the folder. 

    Not sure if this is the same issue but hope it helps someone! 

    Wednesday, September 28, 2016 2:12 PM
  • Dear Corber22,

    Thanks for the simple and straight answer. My issue got resolved with solution

    All others are just saying the common areas to look for the problem. Even MS guys not giving any specific solution.



    Tuesday, October 4, 2016 12:26 PM
  • That did the trick.  I've been fighting with this issue for years, tried deleting temporary files.  It was Adobe yet again screwing with the system and trying to put the blame on Microsoft.  Thanks Michael.
    Wednesday, November 2, 2016 3:52 PM
  • I had the same situation and my preview pane was NOT open.  I also did not feel comfortable with Process Explorer.

    My solution:  I right clicked the folder and discovered there were some contents that were marked as READ-ONLY (General Tab, Attributes section).  So I unchecked the Read-only box, clicked Apply and chose to apply the change to "this folder, subfolders and files", then OK, OK.


    Wednesday, March 1, 2017 3:11 PM
  • I had this same problem on my network folder at my company.  Even though all the 2 files in that folder were closed, it would not let me rename until about 3 seconds after closing EXCEL.  One of the files in there was a spreadsheet and the other was a .pdf.  I had already killed Acrobat processes.  
    Thursday, March 30, 2017 4:40 PM
  • I had this problem too. I found the that the problem was I had Adobe Acrobat PDF files in the Windows/Temp folder. I open one of them and found it was the list of files you have to chose from when you ask to open a previously saved file. I am using Adobe Acrobat CC version.
    Wednesday, May 3, 2017 2:36 AM
  • I applied the MS "disable thumbnail caching in network folder" and it so far I have not had a recurrence of the MS issue.  The article can be found at Folder Rename Fix  

    Thursday, May 18, 2017 2:55 PM
  • A common sense as well as expert answer in a forest of techno-babble. It works! A thousand thanks.

    Sunday, July 2, 2017 7:19 AM
  • Thank you SO much. Your reply/procedure worked in my situation!


    Friday, April 13, 2018 4:47 PM
  • Thanks. acrotray.exe  was the problem. Your solution worked for me. 
    • Edited by Dataryder Sunday, May 6, 2018 6:00 PM
    Sunday, May 6, 2018 5:59 PM
  • Hello!

    It maybe 6 years late, but since this is the first result in my google search I'll let you know what worked for me, after I closed practically everything NON-Windows critical and still finding this impasse.

     1. Control + ALt + Escape to bring the Windows Task Manager.
     2. Go to the "Services" tab.
     3. Find "explorer.exe" on the list.
     4. Right click and end process (this will close all your windows that are related to folder - files viewing.
     5. Go to File, "New task (Run..) "  and type "explorer.exe" and hit "Enter" to recover your Windows bar and the hability to see folders again.
     6. Profit

    OR you could just restart your PC... Whatever works for you.


    Tuesday, October 2, 2018 5:53 PM
  • This has bugged me for years too.  I finally got it to work by installing LockHunter.  It told me that it was WinWord.exe, in my case, that was holding the folder I wanted to rename. So I stopped Word and then it was fine. BTW, I first downloaded and installed the Beta 2 of LockHunter, and it crashed with an access violation.  After uninstalling that, I downloaded the non-beta version, which worked like a charm.
    Monday, December 3, 2018 6:27 PM
  • a bit late to the party (7 years later!), but, hey . . . 

    this did the trick. thank you!

    Wednesday, January 9, 2019 5:17 PM
  • I just create a new folder and name it the way I want.

    Then move everything (from the folder I can't rename) to the new folder.

    Tuesday, November 5, 2019 3:38 PM