Windows 7 "a patch is preventing the system from starting" error code 0x490


  • I have a Windows 7 machine.

    It was working fine.

    Now it will not boot.

    When I try system repair, it says:

    Root cause found

    A patch is preventing the system from starting.

    Repair action: System file integrity cheack and repair

    Result: Failed. Error code 0x490


    I have tried doing safe mode, last known good configuration etc and nothing works

    Also, I tried to restore to an early checkpoint, but it claims that none exist, even thought I know we save restore points.


    Please advise?

    Thursday, February 24, 2011 11:03 AM

All replies

  • Hi

    I have exactly the same problem

    However, I can boot in to safe mode, but fails again when I start up "load basic drivers with diagnostics" using msconfig

    I have restored this partion with an Macrium reflect image created 6 months before and it still fails to load.

    Also I have unplugged everything except the monitor, and still the same

    Any help please?

    • Proposed as answer by Novindius Tuesday, October 7, 2014 3:31 PM
    Thursday, February 24, 2011 4:18 PM
  • "I suggest running Command Prompt from the repair menu and then Check Disk:


    1. Insert the Windows 7 Disc and boot from it.

    2. In the recovery menu, choose Command Prompt .

    3. Type the following command and press Enter:


    Chkdsk /r /f


    Please also try the following commands and press Enter at the end of each line:


    Ren C:\Windows\winsxs\pending.xml pending.old

    Ren C:\windows\SoftwareDistribution SDOLD




    When the register editor opens, please navigate to the following key:




    * High light the COMPONENTS key. Please check if the following values exist in the right pane:





    * If so, please right click on them and choose Delete them. Confirm the operation.

    * Restart the computer."


    Quote from : Vivian Xing


    Thursday, February 24, 2011 4:24 PM
  • This did not work


    firstly C:\Windows\winsxs\pending.xml did not exist

    I did rename C:\windows\SoftwareDistribution




    this did not solve the problem

    any other ideas?

    Thursday, February 24, 2011 11:09 PM
  • Hi,

    You may consider an in place install.

    Also, refer to the following link. 

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Saturday, February 26, 2011 9:33 AM
  • Juke,

    to do an "in place" install, I beleieve I need to be able to boot into windows (which I can not do).

    Can you please advise?

    Monday, February 28, 2011 1:22 AM
  • Hi,

    Can you boot in Safe Mode as Terand says.

    If so, booting in Safe Mode and try an In Place install.

    If it can not, I think you need to do parallel installation.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, February 28, 2011 2:07 AM
  • If anyone else runs into this issue and you recently made some BIOS changes, check your BIOS settings.  I updated my BIOS and loaded defaults like the instructions recommended and didn't realize that my SATA controller was set to AHCI when Windows was setup on my PC.  When the defaults loaded, it went to IDE and I would get a BSoD shortly after the MS flower animation would start.  The minute I changed my SATA settings back to AHCI, it started up normally.
    Monday, April 30, 2012 2:48 AM
  • In my case LKGC worked...
    Wednesday, May 9, 2012 10:29 AM
  • Can you tell us what LKGC is?
    Friday, May 9, 2014 11:15 PM
  • Can you tell us what LKGC is?
    Last Known Good Configuration
    Sunday, May 11, 2014 2:23 PM
  • Hi All

    Just to submit what I found. I have to reset my BIOS earlier and removed the BIOS battery. When I booted up, I got this error.

    It is the BIOS changes. Change them from RAID and AHCI to IDE and it will work a treat.

    • Proposed as answer by DEJT Thursday, September 10, 2015 8:37 PM
    Tuesday, October 7, 2014 3:34 PM
  • Good job!  This answer did it for me and I was trying everything.  Thank you.
    Sunday, May 15, 2016 9:20 PM
  • Worked for me too with a computer that hadn't been turned on in years, and the BIOS battery is dead.
    Saturday, August 18, 2018 5:31 AM