none
Can't record web session in Web Application Transaction Monitoring using IE10 (Tried under Windows Server 2008R2 and 2012)

    Question

  • Hi,

    In Operations Manager Console 2012 SP1 including RU2 I am trying to record a web session in Web Application Transaction Monitoring.

    I have check that:

    I have tried both on a Windows 2008R2 and 2012 server, but the recorder is not showing up as can been seen from Kevin's Blog (link above).

    Any Ideas?

    Thursday, May 09, 2013 9:50 AM

Answers

  • I managed to get this working on both Windows 8 IE10 and server 2012 IE10. Tested on SCOM 2012 SP1 UR2 and UR3. I've done this process in lab and production several times so hopefully this helps you out.

    Checklist:

    1. Ensure that the 64bit IE10 is launching when the "start web-capture" is started in SCOM.

    2. Enable IE10 internet options:

    a: Advanced - Security - Enable Enhanced Protected Mode

    b: Advanced - Browsing - Enable third-party browser extensions

    3. Close all running IE sessions and open the Registry Editor

    4. Registry Change (No reboot needed)

    - Browse to the following regkey:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

    - Add a new DWORD called TabProcGrowth and set it to 0

    5. Registry Change (No reboot needed)

    - Browse to the following regkey:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories64\

    -You should see two subkeys labeled: (These are the cached BHO IE objects related to the Web Recorder)

    {00021493-0000-0000-C000-000000000046}

    {00021494-0000-0000-C000-000000000046}

    - Delete only the above two mentioned keys (This will force IE to recache them next launch)

    6. Try to start the web capture again from SCOM 2012 SP1.

    7. When IE10 Launches enable the add-on again if you are prompted.

    8. If you still don't see the Web-Recorder pane in IE you can now show it by:

     - View - Explorer bars - Web Recorder

    Monday, September 23, 2013 6:40 PM

All replies


  • I think web recorder does not support Internet Explorer 10. For details, please refer to the section “Web Recorder functionality does not work with IE10 on Windows 8”:

    Release Notes for Operations Manager in System Center 2012 SP1
    http://technet.microsoft.com/en-us/library/jj656651.aspx

    Thanks.


    Nicholas Li
    TechNet Community Support

    Tuesday, June 04, 2013 9:21 AM
    Moderator
  • i had same issue & can not find solution for this .. any one can help us
    Sunday, July 14, 2013 12:26 PM
  • I managed to get this working on both Windows 8 IE10 and server 2012 IE10. Tested on SCOM 2012 SP1 UR2 and UR3. I've done this process in lab and production several times so hopefully this helps you out.

    Checklist:

    1. Ensure that the 64bit IE10 is launching when the "start web-capture" is started in SCOM.

    2. Enable IE10 internet options:

    a: Advanced - Security - Enable Enhanced Protected Mode

    b: Advanced - Browsing - Enable third-party browser extensions

    3. Close all running IE sessions and open the Registry Editor

    4. Registry Change (No reboot needed)

    - Browse to the following regkey:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

    - Add a new DWORD called TabProcGrowth and set it to 0

    5. Registry Change (No reboot needed)

    - Browse to the following regkey:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories64\

    -You should see two subkeys labeled: (These are the cached BHO IE objects related to the Web Recorder)

    {00021493-0000-0000-C000-000000000046}

    {00021494-0000-0000-C000-000000000046}

    - Delete only the above two mentioned keys (This will force IE to recache them next launch)

    6. Try to start the web capture again from SCOM 2012 SP1.

    7. When IE10 Launches enable the add-on again if you are prompted.

    8. If you still don't see the Web-Recorder pane in IE you can now show it by:

     - View - Explorer bars - Web Recorder

    Monday, September 23, 2013 6:40 PM
  • The above worked on IE11 also.

    Thanks,

    Doug

    Tuesday, February 04, 2014 5:49 PM
  • This worked perfect for me.  Thanks
    Thursday, February 06, 2014 8:46 PM
  • I performed all of the steps described on both nodes of a new SCOM implementation, but the web recorder pane would just display a blank gray screen. I finally figured out that .net 3.5, not installed by default on Win Server 2012R2, was the prerequisite I needed.

    So if you're scouring the forum posts on this issue, and have tried all of the steps listed and you see a gray pane where the Web Recorder controls should be, make sure you install .NET 3.5.


    • Edited by MarkLBetz79 Wednesday, June 15, 2016 4:44 PM
    Wednesday, June 15, 2016 4:43 PM
  • Addendum: And if you discover that you need .NET 3.5, and you have group policies restricting automatic updates, edit the local group policy on the box in the following way:

    1. Run gpedit.msc
    2. Navigate to Administrative Templates-->System
    3. Find the setting for "Specify settings for optional component installation and repair" and enable it.
    4. Check the box that says: "Contact Windows Update Directly to download repair content instead of Windows Server Update Services."

    Now you can enable .net 3.5 as a feature through Server Manager and it won't choke on the install.

    Wednesday, June 15, 2016 4:44 PM
  • The above worked on IE11 here too. Nice one!
    Friday, October 28, 2016 2:56 PM