none
CentOS Linux VMs will not backup RRS feed

  • Question

  • Hello,

    I have a total of 8 Linux servers part of a protection group that reside on a Hyper-V cluster but 2 of them will not backup via DPM for some odd reason. I have not yet been able to determine why they fail and hope I can find help here.

    Host Info:
    OS: Windows 2012R2
    Hyper-V Cluster with 3 hosts

    DPM Info:
    DPM 2016 v5.0322.0 (Rollup Update 2)

    Linux Info:
    VMs
    OS: CentOS Linux release 7.3.1611 (Core)

    Error:

    Affected area:	Server01
    Occurred since:	4/21/2017 4:14:28 PM
    Description:	The replica of Microsoft Hyper-V Server01 on Server01.Cluster.domain.local is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent. 
    
    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)
    
    	The VSS application writer or the VSS provider is in a bad state. Either it was already in a bad state or it entered a bad state during the current operation. (ID 30111 Details: VssError:The writer experienced a non-transient error.  If the backup process is retried,
    the error is likely to reoccur.
     (0x800423F4))
     
    	More information
    Recommended action:	Please check that the Event Service, the VSS service and the shadow copy provider service is running, and check for errors associated with these services in the Application Event Log on the server CLAVMHOST01.clearent.lan. Please allow 10 minutes for VSS to repair itself and then retry the operation.
    For more information on this error, go to http://go.microsoft.com/fwlink/?LinkId=132612.
    
    	Synchronize with consistency check.
    	Run a synchronization job with consistency check...
    Resolution:	To dismiss the alert, click below
    	Inactivate
    
    	

    Steps taken:

    Ran Consistency checks
    Moved to other VM Hosts
    Rebooted Linux VMs

    I followed the guidance given in the error with no resolution. Other Linux machines are backing up with no problems.


    • Edited by Blacksuit1 Friday, May 5, 2017 3:26 PM changed title
    Wednesday, May 3, 2017 9:03 PM

Answers

  • Hi,

    Until the problem can be investigated inside the guest, you can work around the problem by deselecting the "Backup (volume checkpoint)" option in the integration services settings for that guest.   Make sure the latest IS are installed on that VM. 

    Deselecting the integration services Backup (volume checkpoint) option tells the Hyper-V writer on the host not to invoke a shadow copy inside the running guest. This basically makes a crash consistent backup versus an application consistent backup.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, May 5, 2017 4:21 PM
    Moderator

All replies

  • Hi,

    Until the problem can be investigated inside the guest, you can work around the problem by deselecting the "Backup (volume checkpoint)" option in the integration services settings for that guest.   Make sure the latest IS are installed on that VM. 

    Deselecting the integration services Backup (volume checkpoint) option tells the Hyper-V writer on the host not to invoke a shadow copy inside the running guest. This basically makes a crash consistent backup versus an application consistent backup.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, May 5, 2017 4:21 PM
    Moderator
  • Mike,

    That did the trick my man! Thank you very much...this has been driving me crazy.

    Friday, May 5, 2017 7:37 PM