none
crystal report viewer do not show in internet explorer 11 RRS feed

  • Question

  • I am creating a web application using Visual Studio 2013, and I am using crystal report to do the reporting. Its working pretty fine in firefox, but when come to internet explorer, its show empty.

    Anyone knows how can I resolve this issues? I am research but still can't find a suitable solution.

    your comment and suggestion is much appreciated! 

    Thursday, July 9, 2015 2:55 AM

Answers

  • Hi,

    I think in MSIE browsers its an ActiveX control.

    Make sure ActiveX filtering is not turned on, (Blue circle icon with a line through it in the IE Address bar, click to toggle ActiveX filtering and Tracking protection).

    Tools>Manage Addons>Show all addons.... check that it is not disabled.

    Internet Options>Security tab, click "Reset all zones to default"... there is a setting for scripting of ActiveX controls and Applets.

    you could possibly get a better answer from either a Visual Studio forum or from crystal reports support.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Thursday, July 9, 2015 3:23 AM
  • Hi,

    This could be compatibility issue.

    Please add the site of crystal report into IE compatibility view.

    Fix site display problems with Compatibility View
    http://windows.microsoft.com/en-US/internet-explorer/use-compatibility-view#ie=ie-11

    Here is another solution I found on Developer forum.

    Try to set up the compatibility header mode on the page or the iframe to force it to run on ie7 or ie5, depending the version of crystal that you use:

    $("head, #iframecrystal").append('');

    Hope these could be helpful.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, July 11, 2015 8:06 AM
    Moderator

All replies

  • Hi,

    I think in MSIE browsers its an ActiveX control.

    Make sure ActiveX filtering is not turned on, (Blue circle icon with a line through it in the IE Address bar, click to toggle ActiveX filtering and Tracking protection).

    Tools>Manage Addons>Show all addons.... check that it is not disabled.

    Internet Options>Security tab, click "Reset all zones to default"... there is a setting for scripting of ActiveX controls and Applets.

    you could possibly get a better answer from either a Visual Studio forum or from crystal reports support.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Thursday, July 9, 2015 3:23 AM
  • Hi,

    This could be compatibility issue.

    Please add the site of crystal report into IE compatibility view.

    Fix site display problems with Compatibility View
    http://windows.microsoft.com/en-US/internet-explorer/use-compatibility-view#ie=ie-11

    Here is another solution I found on Developer forum.

    Try to set up the compatibility header mode on the page or the iframe to force it to run on ie7 or ie5, depending the version of crystal that you use:

    $("head, #iframecrystal").append('');

    Hope these could be helpful.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, July 11, 2015 8:06 AM
    Moderator