none
Office 365 email authentication RRS feed

  • Question

  • Hi,

    we need to configure fim to send notification emails to user through Office 365 email service.

    We implemented the notification workflow but it send no email. The event viewer shows this error:

    System: System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated

       at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)

       at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)

      at System.Net.Mail.SmtpClient.Send(MailMessage message)

       at Microsoft.ResourceManagement.Mail.IlmSmtpClient.Microsoft.ResourceManagement.Mail.ISmtpInterop.Send(MailMessage )

       at Microsoft.ResourceManagement.Mail.SmtpServer.SendGenericMessage(GenericMessage message)

       at Microsoft.ResourceManagement.Mail.NotificationMessage.Send()

       at Microsoft.ResourceManagement.Workflow.Hosting.SendMailWorkItemProcessor.SendMailMessage(MessageContent messageContent)

       at Microsoft.ResourceManagement.Workflow.Hosting.SendMailWorkItemProcessor.ProcessWorkItem(WorkItem workItem)

    Can you help me?

    Thanks in advance.

    Francesca



    • Edited by Francesca85 Thursday, July 19, 2012 12:19 PM
    Thursday, July 19, 2012 11:24 AM

Answers

All replies

  • You may be able to configure default SMTP credentials in the Service's .config file as per http://msdn.microsoft.com/en-us/library/ms164242.aspx

    I took a quick peek at Microsoft.ResourceManagement.Mail.IlmSmtpClient and it's basically a wrapper around the regular System.Net.Mail.SmtpClient.

    --Steve

    Thursday, July 19, 2012 3:55 PM
  • Hi did you ever find a solution for this?
    • Proposed as answer by FIM_Admin Monday, April 29, 2013 8:44 PM
    • Unproposed as answer by FIM_Admin Monday, April 29, 2013 8:44 PM
    Thursday, April 25, 2013 9:46 PM
  • I got this working via this document. Be sure to set the following in Microsoft.ResourceManagement.Service.exe.  Use localhost if you are setting up IIS/SMTP on the same box:

     <appSettings>
        <add key="mailServer" value="localhost" />
        <add key="isExchange" value="0" />
        <add key="sendAsAddress" value="myGmailAddr@domain.com" />
        <add key="synchronizationServerName" value="my.fimSync.com" />
      </appSettings>

    • Proposed as answer by FIM_Admin Monday, April 29, 2013 8:47 PM
    Monday, April 29, 2013 8:47 PM
  • I wouldn't recommend this configuration--it will break FIM's standard email workflow capabilities.  There is also a high chance of outbound mail being marked as spam without using a properly-setup smarthost.

    Steve Kradel, Zetetic LLC

    Monday, April 29, 2013 8:57 PM