Missing Lync 2013 Enterprise Services?


  • Hi all,

    I have Lync 2013 Enterprise Edition two Front-End servers. It seems that I am missing some services. For example, I am missing the following:

    • Lync Audio Test Service
    • Lync 2013 Conferencing Announcement Service
    • Lync Server Bandwidth Policy Service
    • Lync Server Conferencing Attendant service (dial-in conferencing)

    I have Enterprise Voice enabled in my Topology Builder. Which should enable some of the services.

    Any thoughts?


    • Edited by WATER004 Thursday, June 20, 2013 8:26 AM
    Thursday, June 20, 2013 8:25 AM


All replies

  • Hi again,

    Ok, I tried to uncheck "Enterprise Voice" and "Conferencing" -> Publish, then re-check "EV" "Conferencing" and "Dial-In" -> Publish.

    Once I did that, I was now able to get Conferencing Announcement Service and Conferencing Attendant service.

    However, I'm still missing Audio Test Service and Bandwidth Policy Service.

    Help please?

    Thank you!

    Thursday, June 20, 2013 2:07 PM
  • Have you enabled Call Admission Control in the Topology builder and the Lync Server Control Panel (Network Configuraiton)? Have you ran the Lync 2013 Deployment Wizard - Step 2 again on each Front End after changing the Topology?
    Thursday, June 20, 2013 6:32 PM
  • In Topology Builder Make sure the Front End pool is assigned to the Call Admission Control as well.
    Thursday, June 20, 2013 6:40 PM
  • Great, I got the Bandwidth Policy! Thanks for that!

    Although it's pretty weird, I can't seem to get to install the Lync Server Audio Test.

    I have Enterprise Voice enabled, which they say installs the service. Here is a screenshot of my topology builder:

    And here is a screenshot of the services running:

    Please help?

    Thank you!

    Friday, June 21, 2013 2:04 AM
  • Please post the results after running Get-CsAudioTestServiceApplication in the Lync Server Management Shell.  Do you have more then one Front End pool (maybe 2010 servers)?
    Friday, June 21, 2013 3:32 AM
  • Here is the screenshot:

    I noticed in the BootStrapperLog, after installing the new features (ex. Enterprise Voice), there is no installation happening for ATS.msi, which I think is for the Audio Test Service.

    I really hope that this problem can be solved.


    Edit: I only have 1 Front End Pool, sitting on Lync Server 2013.

    • Edited by WATER004 Friday, June 21, 2013 4:09 AM Format
    Friday, June 21, 2013 3:46 AM
  • Try manually running the ATS.msi file.
    Friday, June 21, 2013 5:22 AM
  • Might have to do something like: CMD /C Msiexec /i Setup\Ats.msi ADDLOCAL=Feature_Ats REBOOT=ReallySuppress INSTALLDIR=”c:\lyncinstallmedia” /QB! /L*v “c:\temp\Feature_Ats.log”

    Taken from this blog:

    Friday, June 21, 2013 5:30 AM
  • Hi,

    Is there any update on the issue?

    Have you even changed sip domain during deployment?

    Please make sure the server meets the requirements for Lync Server.

    Kent Huang
    TechNet Community Support

    Friday, June 21, 2013 7:12 AM
  • Thanks again Michael,

    I tried manually running the ATS.msi, but it gives me error 2819. Control [3] on dialog [2] needs a property linked to it. I tried this using both the one found in programdata\Microsoft\Lync Server\... and using the actual .iso file.

    I also tried that link you gave. It returns success but doesn't add anything to the Services.msc. I tried restarting, but nothing happened. However, when I click on the ats.msi, it asks if I want to remove the service.

    I really hope we can solve this.


    Friday, June 21, 2013 7:29 AM
  • A few people manually added some lines to the topology file (Not supported by MS) to get the ATA service installed:

    • Marked as answer by WATER004 Monday, June 24, 2013 5:26 AM
    Friday, June 21, 2013 1:41 PM
  • Thanks for that! I will try that and get back to you regarding the results.
    Saturday, June 22, 2013 5:45 AM
  • Hey Michael,

    Seems like manually adding the testbot in topology did the trick.


    Monday, June 24, 2013 5:25 AM