locked
Access to SharePoint RRS feed

  • Question

  • I have successfully setup Forefront to allow access to an internal sharepoint site from the Internet, however, it is looking for the user to authenticate twice.

    Once via the Forefront security, then a windows dialog box appears for secondary authentication.

    How can I overcome this and allow the user to authenticate once, throught he forefront page?

    Thursday, July 29, 2010 8:47 AM

Answers

  • Ok, can you provide some information on how you configured the application using the UAG SharePoint template?

    The Authentication tab on the UAG SharePoint application is used to provide information on SSO which is used to automatically send credentials to the published server (SharePoint in this case). For a standard sharepoint deployment this would be configured to use 401 and the repository used for authentication would be added to the SSO list.

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    • Proposed as answer by ZarkoC Friday, July 30, 2010 10:03 AM
    • Marked as answer by Erez Benari Friday, July 30, 2010 6:03 PM
    Thursday, July 29, 2010 11:10 AM

All replies

  • Forefront what? Do you mean Forefront TMG or Forefront UAG?


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Thursday, July 29, 2010 9:09 AM
  • Forefront UAG
    Thursday, July 29, 2010 10:07 AM
  • Ok, can you provide some information on how you configured the application using the UAG SharePoint template?

    The Authentication tab on the UAG SharePoint application is used to provide information on SSO which is used to automatically send credentials to the published server (SharePoint in this case). For a standard sharepoint deployment this would be configured to use 401 and the repository used for authentication would be added to the SSO list.

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    • Proposed as answer by ZarkoC Friday, July 30, 2010 10:03 AM
    • Marked as answer by Erez Benari Friday, July 30, 2010 6:03 PM
    Thursday, July 29, 2010 11:10 AM
  • I'm experiencing the same issue that Gary001 stated above.  I've got a Sharepoint 2010 server being published through UAG.  I authenticate into the UAG server, and when I click on the Sharepoint link within the UAG portal, I get prompted for credentials again.  I used the Sharepoint 2010 template to publish the Sharepoint site, and if I enter the credentials the 2nd time, I successfully get redirected to the Sharepoint site.  In the application properties of the Sharepoint app, under the Authentication tab, I have "Use SSO" selected, "Use credentials for SSO" selected with a DC as the selected authentication server, and for "Select an authentication method" I have "Both" selected, although I've tried "401 Request" and "HTML form" individually.

    Any thoughts or suggestions on this would be greatly appreciated.  I've scoured the net trying to find a solution for this, but everything that I seem to find involves using FBA.

    Thanks!

    Jason

    Wednesday, February 8, 2012 2:41 PM
  • @ Jason

    Unselect the follow if your just publishing an SP2010 Site.

    Under Trunk Configuration, Click Configure trunk settings:

    Click Authentication (Untick - Require users to authenticate at session logon)

    Go to the session tab, and select "Disable Component installation and activation"

    Save, and activate


    Thursday, February 9, 2012 5:01 AM
  • Michael,

    Ultimately there will be more that just Sharepoint published, so turning off the Authentication and Endpoint Checking really isn't an option.  However, I did try your suggestion, but I still got prompted for a login to Sharepoint when clicking on the link.

    Jason

    Thursday, February 9, 2012 2:46 PM