locked
audit reports display XML instead of in excel RRS feed

  • Question

  • I have sharepoint 2007, office 2010 and win7.

     

    when I go to site actions, site settings, audit log reports, I get.  The following info...there's a lot more...but....

     <?xml version="1.0" ?>
    <?mso-application progid="Excel.Sheet"?>
    - <Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:x="urn:schemas-microsoft-com:office:excel" xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882" xmlns:s="uuid:BDC6E3F0-6DA3-11d1-A2A3-00AA00C14882" xmlns:rs="urn:schemas-microsoft-com:rowset" xmlns:z="#RowsetSchema" xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet" xmlns:html="http://www.w3.org/TR/REC-html40">
    - <DocumentProperties xmlns="urn:schemas-microsoft-com:office:office">
    <Version>11.6408</Version>
    </DocumentProperties>
    - <ExcelWorkbook xmlns="urn:schemas-microsoft-com:office:excel">
    <HidePivotTableFieldList />
    </ExcelWorkbook>
    - <Styles>


    and it goes on ....
     

    • Edited by Bryan - COE Thursday, September 8, 2011 10:35 PM
    Thursday, September 8, 2011 10:31 PM

Answers

  • This is what worked for me.

     

    Tools, internet options, advanced (reset) reset everything including "Delete personal settings"

     

    After that ALL things that didn't work in IE9 now are resolved.  I had no addons toolbars etc...

    • Marked as answer by Bryan - COE Wednesday, September 14, 2011 11:27 PM
    Wednesday, September 14, 2011 11:27 PM

All replies

  • Try repairing Office 2010 from Control Panel - Add or Remove features - Click on Office 2010 and from the right hand side , select Change - Repair.

    Even if that doen't solve there is a workaround for this. When you open the Audit reports , it opens up in XML from IE - Correct ?

    Let it open and from that IE click on File Save - Save it to the desktop with the Default name and Extension. Once it is saved close the IE and open the file from your desktop by either Double clicking on it or Right click open with Excel. It will open in Excel

    Hope this Helps


    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, September 9, 2011 2:17 AM
  • Hi,

    What do you see if you seethe same from other browser?

    IF you access it from a machine that has Office 2007 are you getting the same error?

    Try repairing your office 2010 installation.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Friday, September 9, 2011 2:40 AM
  • This is what worked for me.

     

    Tools, internet options, advanced (reset) reset everything including "Delete personal settings"

     

    After that ALL things that didn't work in IE9 now are resolved.  I had no addons toolbars etc...

    • Marked as answer by Bryan - COE Wednesday, September 14, 2011 11:27 PM
    Wednesday, September 14, 2011 11:27 PM