none
Query Web Service Exception RRS feed

  • Question

  • I'm using FAST Search for SharePoint Query Web Service and it throws exception while invoking the QueryEx method.

    By looking at ULS logs I found following errors.  Its look like this happen while generating the Results XML.  Any suggestions please ? 

     

    XMLBuilder::BuildSharePointXmlResult--Encountered an invalid hithighlighted element (Not valid XML content). Encoding fragment instead. Ex: System.Xml.XmlException: An error occurred while parsing EntityName. Line 1, position 197.     at System.Xml.XmlTextReaderImpl.Throw(Exception e)     at System.Xml.XmlTextReaderImpl.ParseEntityName()     at System.Xml.XmlTextReaderImpl.ParseEntityReference()     at System.Xml.XmlTextReaderImpl.Read()     at System.Xml.XmlLoader.ParsePartialContent(XmlNode parentNode, String innerxmltext, XmlNodeType nt)     at System.Xml.XmlDocumentFragment.set_InnerXml(String value)     at Microsoft.Office.Server.Search.Query.Gateway.XMLBuilder.BuildSharePointXmlResult(XmlDocument xmlDoc, String newElement, ResultTable resultTable, CultureInfo siteCulture) 

    Wednesday, June 22, 2011 3:12 AM

All replies

  • Hi rumesh,

    Seems you might have hit a bug. You can try to isolate the hit which causes the error by adding more search words, and execute against the Query method instead in order to get the data once you have the hit isolated.

    Then you can examine the data and see if you can find any weird characters which might cause the XML generation error.

    Regards,
    Mikael Svenson 


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Friday, June 24, 2011 12:12 PM