locked
Outlook 2007 OST Redirection RRS feed

  • Question

  • My laptop users OSTs have been redirected to a file server. This isn't working as the link to the server is quite slow. I want to make the OST location the normal C: drive location on the laptop. I tried a GPO under Administrative Templates, Outlook 2007, Miscellaneous, PST Settings and changed both the Default Location for PST and OST files and the Default location for OST files to %userprofile%\Local Settings\Application Data\Microsoft\Outlook but the darned OST keeps being created on the file server anyway. So I was wondering if there is a registry setting I can change on the laptops that will have the same effect?

    Thursday, July 22, 2010 2:03 PM

Answers

  • Run GPUpdate from the command line from the workstation to refresh the GPO settings and then GPResult to see if that GPO is still applied.

    If all else fails, logoff/logon or simply reboot the workstation and run GPResult again to see if its still applied.

     

    Saturday, July 24, 2010 12:59 PM
    Moderator
  • After running the gpupdate as Andy suggests try the following on a test user. The OST file won't move back by simply turning off the GPO. You would either need to turn it off and then follow the procedure below or enable the GPO and point it back to a local drive. The situation your in now is you had the GPO enabled and had it pointed to a path, the ost was created,the gpo was turned off. So now the OST location is not forced but it is valid so it still is working. Try the below on one user manually if that works you can try it via gpo setting the location to %appdata%\Microsoft\Outlook

     

    1. Go into Tools | Account Settings
    2. [A] On the Data Files tab select the data file for the account
    3. [B] Turn off "Cached mode" on the "advanced" tab
    4. [C] Disable "Offline use" on the "offline folder" settings popup
    5. And then.... you can move the .ost (in Explorer) and reference the new location to have Outlook work with it
    6. When you've finished don't forget to re-enable "Offline use" and turn "Cached mode" back on - otherwise you'll only be able to work when connected to the remote server

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Saturday, July 24, 2010 5:36 PM

All replies

  • What is making your users OST redirect to the file server? Are you using roaming profiles or some other redirection?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, July 23, 2010 2:43 AM
  • Why don't you use the outlook in cached mode?

    Outlook in cached mode will create the OST files in local hard disc.

    You also could delete the ForceOSTPath key in regedit according the below article:

    You cannot specify a separate folder to store the .ost file when you use the ForcePSTPath value in Outlook 2003
    http://support.microsoft.com/kb/896591

    You also can use the following Office Group Policy template to configure OST settings. Load Outlook policies, find "PST Settings". For more information, please refer to the following articles.

    Administrators can use Office policy templates with the Group Policy settings of Windows
    http://support.microsoft.com/kb/826170

    Thanks


    Your expertise never fails to impress!

    Friday, July 23, 2010 4:48 AM
  • The folder was redirected to the file server by a setting  under Administrative Templates, Outlook 2007, Miscellaneous, PST Settings  - Default Location for PST and OST files. Then a GPO from above enabled cached mode which started the OSTs. Now I am trying to get the OST and PST back to the default location but it keeps going to the file server even though I took the file server path out of the setting.
    Friday, July 23, 2010 9:30 PM
  • Run GPUpdate from the command line from the workstation to refresh the GPO settings and then GPResult to see if that GPO is still applied.

    If all else fails, logoff/logon or simply reboot the workstation and run GPResult again to see if its still applied.

     

    Saturday, July 24, 2010 12:59 PM
    Moderator
  • After running the gpupdate as Andy suggests try the following on a test user. The OST file won't move back by simply turning off the GPO. You would either need to turn it off and then follow the procedure below or enable the GPO and point it back to a local drive. The situation your in now is you had the GPO enabled and had it pointed to a path, the ost was created,the gpo was turned off. So now the OST location is not forced but it is valid so it still is working. Try the below on one user manually if that works you can try it via gpo setting the location to %appdata%\Microsoft\Outlook

     

    1. Go into Tools | Account Settings
    2. [A] On the Data Files tab select the data file for the account
    3. [B] Turn off "Cached mode" on the "advanced" tab
    4. [C] Disable "Offline use" on the "offline folder" settings popup
    5. And then.... you can move the .ost (in Explorer) and reference the new location to have Outlook work with it
    6. When you've finished don't forget to re-enable "Offline use" and turn "Cached mode" back on - otherwise you'll only be able to work when connected to the remote server

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Saturday, July 24, 2010 5:36 PM
  • Actually, I wouldnt even bother moving the .ost. It will get recreated in the default location once you go back to cache mode.
    Saturday, July 24, 2010 5:51 PM
    Moderator
  • I don't know if Larry7995 has been able to resolve this problem, but I am also in the same situation. The GPO is active and being applied with new settings, however it is only being effective on new outlook profile. The ost file is not being relocated in any existing profile.

    I have already tried the manual procedure as described by Scott, but this can only be a solution when a handful of user configuration are involved. An automation would be needed to make such changes enterprise-wide, which is in my case and it might be that of Larry7995 as well. It is Outlook2010 in my case, but I believe ît should be the same procedure with 2007.

    Any other idea in moving OST file in an already existing outlook profile in a large scale?

    Thanks


    • Edited by topokin Monday, April 30, 2012 7:17 AM
    Monday, April 30, 2012 7:14 AM