none
Rule for Public Folder not working for external senders - was working before applying CU9

    Question

  • Dear all,

    I have a Public Folder to which mails are BCC'd by a rule. Mails from internal senders end up in the Public Folder as expected but mails from external senders (hotmail, gmail, etc.) don't.

    The rule was working before I installed CU9. Now I have installed CU10 now but the problem persists.

    I have checked the permissions, tried creating new rules but none of these has helped.

    Can someone help me fix this problem? Thanks in advance.


    Prashant


    • Edited by prash_msdn Wednesday, November 4, 2015 8:26 AM
    Wednesday, November 4, 2015 8:26 AM

Answers

All replies

  • If you believe that CU9 has a bug that changed behavior, the place to get it resolved is through Microsoft Support.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, November 4, 2015 5:51 PM
    Moderator
  • Dear all,

    I have a Public Folder to which mails are BCC'd by a rule. Mails from internal senders end up in the Public Folder as expected but mails from external senders (hotmail, gmail, etc.) don't.

    The rule was working before I installed CU9. Now I have installed CU10 now but the problem persists.

    I have checked the permissions, tried creating new rules but none of these has helped.

    Can someone help me fix this problem? Thanks in advance.


    Prashant


    Hi Prashant,

    If possible, please share your Rule condition to confirm whether there is any additional settings for external senders.

    Additionally, also check if there is any other transport rule with the condition 'The sender is located outside the organization' in your Exchange server. The Priority for the rule would cause different results for the action.

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Thursday, November 5, 2015 3:01 AM
    Moderator
  • Hi Prashant,

    How about a test rule from tom@hotmail.com to be bcc'd to Testmailbox@contoso.com is that working. Basically not redirecting it to the PF, but normal mailbox or maybe a new PF residing in a different PFmailbox\DB\Server


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, November 5, 2015 3:56 AM
  • Hi Winnie/Satyajit,

    Sorry for the delay in replying. Busy fighting other fires.

    The rule that is not working is:

    If the message...
    Is received from 'address1@external1.com' or 'address2@external2.com'

    Do the following...
    Blind carbon copy(Bcc) the message to 'publicfolder@internal.com'

    Except if...
    Is sent to 'address3@internal.com'

    If I add my internal email address to the BCC list, I receive the email but the public folder does not. Also, as I mentioned in my first post, emails from internal addresses matching my other rules end up in the public folder correctly.


    Prashant

    Friday, November 13, 2015 7:33 AM
  • Hi Prash,

    As far as I remember, something that prevents external senders on the mailboxes or DLs in Ex2003 was the AUthenticated Users Only checkbox in AD.

    Open the properties of the mailbox and select Mailbox Features, then scroll down to the Message Delivery Restrictions and click View Details.

    Enabling the option to “Require that all senders are authenticated” will have the effect of rejecting emails from external senders.

    exchange-2013-message-delivery-restrictions-02

    Get-MailPublicFolder PFname | fl AcceptMessages*,RequireSenderAuthenticationEnabled

    If thats all set correctly, then lets not actually try to find the issue right now or solve it, but rather figure out a workaround. If that works we can figure out why your current method doesn't work.

    Test1:

    External -> Rule forwarding it to a test@internal.com mailbox , similar to what you did "add my internal email address to the BCC list" , but don't add the publicfolder@internal.com here. -> on the test mailbox setup a forwarder  to forward any emails to the publicfolder@internal.com without any copy.

    Test2:

    If there is an entry in GAL use .Then create a DL and add the PF as the member.

    And on the rule set the DL as the destination.

    References:

    Block External Emails for an Exchange Server 2013 Mailbox

    http://exchangeserverpro.com/block-external-emails-exchange-server-2013-mailbox/


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.


    • Edited by Satyajit321 Friday, November 13, 2015 11:04 AM
    Friday, November 13, 2015 11:04 AM
  • Hi,

    My issue was related to the Mail-Enabled Public Folder Permission Changes made in CU6.

    https://technet.microsoft.com/library/jj150489(v=exchg.150).aspx#PF

    I granted Create Items permission to Anonymous user to resolve the issue.

    Add-PublicFolderClientPermission "\Public Folder Name" -AccessRights CreateItems -User Anonymous

    Thanks for all your help.


    Prashant

    • Marked as answer by prash_msdn Tuesday, November 24, 2015 4:24 AM
    Tuesday, November 24, 2015 4:24 AM
  • Hi,

    this doesn´t work for me, when I set the Method to forward the Original Message. I think its Called "Leave message intact" in the English client. When I set the standard forward method it works but that doesn´t look nice. The message then has this stupid "FW: Subject" forward things in it.

    The permission createitems to anonymous was already set. I also tryed to delete all permissions in the folders and set them new. And i tryed to set full rights but this doesn´t help either.

    I updated from CU6 to CU10 and now i have that problem.

    Thanks
    Sintra

    Tuesday, November 24, 2015 8:51 AM
  • Hi,

    My issue was related to the Mail-Enabled Public Folder Permission Changes made in CU6.

    https://technet.microsoft.com/library/jj150489(v=exchg.150).aspx#PF

    I granted Create Items permission to Anonymous user to resolve the issue.

    Add-PublicFolderClientPermission "\Public Folder Name" -AccessRights CreateItems -User Anonymous

    Thanks for all your help.


    Prashant

    Good find Prash. Totally skipped my mind.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Tuesday, November 24, 2015 11:51 AM