locked
...\Program Files\SMS_CCM\SMS_MP\web.config gone RRS feed

  • Question

  • Bit of background 1st ... I have an SCCM 2012R2 sp1 Single server setup. Site version is 5.00.8239.1000 (Console Ver.: 5.0.8239.1502). Recently our system started failing; we could not get clients to see Task Sequences, install clients, or push updates. The MP is in a Critical state. The logs continually throw this error: "MP Control Manager detected management point is not responding to HTTP requests.  The HTTP status code and text is 500, Internal Server Error."I've done the uninstall reinstall of the MP, ensured there isn't an issue with IIS or the ports, that there is no Firewall in play.  SQL also seems to be configured properly.  The one thing that LOOKS like it might be the problem is what I mention in my question Title.  On the drive where SCCM is installed, in the \Program Files\SMS_CCM\SMS_MP\ directory, there is a single file "web.config" BUT all it contains is the following:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.web>
            <authentication mode="Windows" />
        </system.web>
    </configuration>
    
    Is this my problem?? And can I recover from it without having made a copy of this file or configured the 'Backup Site Server' maintenance task for the site?  Or have I ultimately shot myself in the foot?

    # When I wrote this script only God and I knew what I was doing. # Now, only God Knows!

    Wednesday, October 25, 2017 8:42 PM