locked
RHEL Clients with MS PKI RRS feed

  • Question

  • I am having a real hard time tracking down the reason why i am getting the following error message. 

    the Install I am using is the following.

    ./install -mp SCCMserver.domain.com -sitecode ABV  -UsePKICert CERTwithPK.pfx -certpw P@ssword01 -CRL CRLfile.crl /tmp/SCCM/ccm-Universalx64.tar

    

    I have regenerated the client certificate in multiple ways multiple times and everything seems go be good with the cert. I followed the advice of the following post Old Article.

    the /var/opt/microsoft log never gets generated so i cant see if anything is really happening on this client or not. How else can I move forward troubleshooting this?


    • Edited by I_Know_God Wednesday, August 23, 2017 7:58 PM Added install code
    Wednesday, August 23, 2017 6:52 PM

Answers

All replies

  • Hi,

        Is this issue occurred on multiple RHEL clients? There are several suggestions for your reference as below:

       1. Try to use the -NoCRLCheck parameter in your command line.

       2. When exporting the PKI cert, please remember to check the option "Include all certificates in the certification path if possible".

       3. The prerequisites for deploying ConfigMgr client for Linux should be met in this docs based on your RHEL version:

    https://docs.microsoft.com/en-us/sccm/core/clients/deploy/plan/planning-for-client-deployment-to-linux-and-unix-computers 

    Regards,

    Jimmy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, August 24, 2017 11:20 AM
  • The -nocrlcheck command seemed to work just fine.. though that kind of sucks. my CRL is in good format and it found the CRL upon import previously so im not sure why it wouldnt take it this time around. 
    Thursday, August 24, 2017 2:33 PM