none
[Fixed] Windows 10 Hangs on Secure Boot RRS feed

  • Question

  • Edit: Fixed, and without re installing windows !

    ---------- after hours on the phone to Dell support and much frustration and research ----------------

    The problem is when you shutdown (and start up ) the system, Wininit.exe is run with the command line autocheck autochk *  from the registry key below, this causes autocheck ( an ntfs version of chkdsk  " per microsoft: Autochk.exe is a version of Chkdsk that runs only on NTFS disks and only before Windows... . Autochk cannot be run directly from the command-line"

    The accepted method of changing this registry setting is by use of "Chkntfs.exe command-line tool ,

    but it only seems to allow excluding some drives from getting scanned.

    I deleted the contents of this key and my system runs with secure boot again and does not hang on start up and shutdown. The last windows update had some interesting side effects.

    I am waiting for Dell to update some drivers and I can then go back to Autochk, it is only supposed to run on drives where the "dirty bit" is set but seems to fail on getting any information from the drive and the default 5 minute timeout on shutdown and start up for each drive takes quite a while.

    I am most pleased that I did not have to re install windows!!!!!

    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager BootExecute REG_MULTI_SZ set to blank and I am up and running again

    ...................................................

    3/4/2016 windows updates installed fine, I used the PC for the day and shut down as per normal.

    4/5/2016 I started the PC and my apps ran fine, the latest update fixed my explorer problems with the screen fonts at 175 % thank you.

    I could not shut down the PC.

    I have a Dell Area-51 R2 Bios A03 with a 4k screen

    I tried shutdown -s -f and no joy, task manager/resource monitor analyze wait chain said shutdown was waiting for wininit.exe

    After 30 minutes I held the power switch for a while and it shut down.

    When I tried to reboot it hung, no F2.

    I shut down with the power switch, pulled the power cord, re inserted the power cord and this time F2 worked.

    After a few cycles of this hang, hold power switch, pull the power cord I disabled secure Boot.

    Now it shut down and restarted fine, I enabled Secure boot, re installed the keys etc and the same hang.

    I am back running without secure boot.

    What must be done to get secure boot up again ?


    Saturday, March 5, 2016 10:51 PM

Answers

  • S. Sengupta,

    Note my fix at the top of my OP.

    No resetting the Bios ( it already was at factory ) and no re installing windows required.

    The Fix

    ---------- after hours on the phone to Dell support and much frustration and research ----------------

    The problem is when you shutdown (and start up ) the system, Wininit.exe is run with the command line autocheck autochk *  from the registry key below, this causes autocheck ( an ntfs version of chkdsk  " per microsoft: Autochk.exe is a version of Chkdsk that runs only on NTFS disks and only before Windows... . Autochk cannot be run directly from the command-line"

    The accepted method of changing this registry setting is by use of "Chkntfs.exe command-line tool ,

    but it only seems to allow excluding some drives from getting scanned.

    I deleted the contents of this key and my system runs with secure boot again and does not hang on start up and shutdown. The last windows update had some interesting side effects.

    I am waiting for Dell to update some drivers and I can then go back to Autochk, it is only supposed to run on drives where the "dirty bit" is set but seems to fail on getting any information from the drive and the default 5 minute timeout on shutdown and start up for each drive takes quite a while.

    I am most pleased that I did not have to re install windows!!!!!

    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager BootExecute REG_MULTI_SZ set to blank and I am up and running again

    Monday, March 7, 2016 12:15 AM

All replies

  • Enter the BIOS -try resetting the BIOS back to the factory settings. Save changes and exit. Now recheck.

    If the above doesn't help then try "Reset this PC" keeping your personal files intact.

    For additional troubleshooting steps for PC manufacturers: see Secure Boot isn't configured correctly: Determine if the PC is in a manufacturing mode (info for manufacturers).

    [same is applicable for Win 10]


    S.Sengupta, Windows Experience MVP

    Saturday, March 5, 2016 11:56 PM
  • I have already reset the Bios to factory ( sorry, my error  I failed to mention that in my original post ).

    "Reset this PC" will remove all my applications I have carefully installed and vetted to insure they work as intended, though yes it will keep my "personal" data files intact while all the Microsoft OS applications are re installed.

    I find it difficult to understand that Dell mis configured Secure Boot and it took 3 months to show up.

    Obviously Secure Boot is coughing on something and Secure Boot is unwilling to share the offending item, If I had to guess I would say the search engine in edge that I managed to configure to allow google as it has miraculously now allowed me to choose bing again. I will remove the registry hack that permitted the choice of other than bing as the search engine and quit using edge and see if secure boot will work again as a matter of curiosity.

    I am only interested in getting my work done, I do not object to using "Secure Boot" but I am not willing to be held hostage and be put to the trouble of re installing all my applications over and over and over again.

    I will continue to run without secure boot till Microsoft hangs my PC again.

    I have been a loyal Microsoft supporter since the beginning with MsBasic, MsDos etc. , I will continue to use Microsoft but I find these interruptions tiresome as I get older.

    Sunday, March 6, 2016 12:23 AM
  • S. Sengupta,

    Note my fix at the top of my OP.

    No resetting the Bios ( it already was at factory ) and no re installing windows required.

    The Fix

    ---------- after hours on the phone to Dell support and much frustration and research ----------------

    The problem is when you shutdown (and start up ) the system, Wininit.exe is run with the command line autocheck autochk *  from the registry key below, this causes autocheck ( an ntfs version of chkdsk  " per microsoft: Autochk.exe is a version of Chkdsk that runs only on NTFS disks and only before Windows... . Autochk cannot be run directly from the command-line"

    The accepted method of changing this registry setting is by use of "Chkntfs.exe command-line tool ,

    but it only seems to allow excluding some drives from getting scanned.

    I deleted the contents of this key and my system runs with secure boot again and does not hang on start up and shutdown. The last windows update had some interesting side effects.

    I am waiting for Dell to update some drivers and I can then go back to Autochk, it is only supposed to run on drives where the "dirty bit" is set but seems to fail on getting any information from the drive and the default 5 minute timeout on shutdown and start up for each drive takes quite a while.

    I am most pleased that I did not have to re install windows!!!!!

    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager BootExecute REG_MULTI_SZ set to blank and I am up and running again

    Monday, March 7, 2016 12:15 AM
  • Hi Jim,

    I am writing here to inform that I edited your last reply with the fix you posted. If this causing anything uncomfortable, I apologize here.

    Thank you for you sharing and update. To make this thread more convenient for the others to realize the fix, I marked your last reply with the fix.

    Thank you again for your understanding, and if any further questions, please feel free to post in TechNet.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, March 7, 2016 2:32 AM
    Moderator
  • No problem, Thank you Michael
    Monday, March 7, 2016 3:23 AM
  • Glad to know that you have fixed the problem.

    Relax and enjoy Windows 10. :)


    S.Sengupta, Windows Experience MVP

    Monday, March 7, 2016 3:34 AM
  • S. Sengupta,

    I will relax when microsoft updates windows to fix the "autocheck bug" so I can go back to a stock configuration, my fix is a band aid to work around a problem not of my own making.

    checkdsk reports the dirty flag is not set on any of my drives as does Chkntfs so why does autocheck hang trying to interrogate the drive to get the dirty flag ?

    Monday, March 7, 2016 2:24 PM