Error when trying to protec VM using backup using child partition snapshot RRS feed

  • Question

  • Hi,

    I have been using DPM since 2007 with version 2007.  I have upgraded to version 2010 in the past 6 months.  I have always protected my VM's by installing protection agents within the vm/guest OS.  Since upgrading to 2010 and now having the storage space needed, I wanted to start trying to backup my hyper-v vm's using the backup using child partition snapshot option.  The first time I tried, the replica creation failed, but was able to complete with a consistency check.  I then found out that I needed to add the Hyper-V role to my DPM server to do ILR recovery.  which I did successfully.  All backup jobs have failed since.  I have also since deleted all my vm replicas.  Everytime I try to create a new protection group for child partition snapshots, replica creation fails and consistency checks fail.

    Hyper-v server is Server 2008 R2 SP1. It is a standalone server with VM's on local storage [4+ TB HP MSA70 controller. Disk is GPT]

    DPM Server is also Server 2008 R2 SP1

    VM's are a mix of server 2003 and server 2008 and R2

    To recreate the issue, I reboot my Hyper-V server to reset the VSS writer, check writers and all are stable.  Start job on DPM server, within 1-2 minutes the job fails with the error below. Look at event viewer on Hyper-V server and see that dpmra.exe failed. check vss writers on Hyper-V Server after job failure and the Hyper=v vss writer is "waiting to complete" [see error below].  Check Event viewer in protected VM and no reference/errors on VM.

    DPM Failed Job Details

    Type: Replica creation
    Status: Failed
    Description: The protection agent on "Hyper-V Server" was temporarily unable to respond because
    it was in an unexpected state. (ID 60 Details: Internal error code: 0x809909B0)
     More information
    End time: 6/17/2012 3:46:11 PM
    Start time: 6/17/2012 3:45:09 PM
    Time elapsed: 00:01:02
    Data transferred: 0 MB
    Cluster node -
    Source details: \Backup Using Child Partition Snapshot\2K8VM03
    Protection group: Hyper-V VM's

    Event viewer error from Hyper-V Server

    Application Error Event ID 1000
    Faulting application name: DPMRA.exe, version: 3.0.8180.0, time stamp: 0x4ec6357f
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e21213c
    Exception code: 0x80070057
    Fault offset: 0x000000000000cacd
    Faulting process id: 0x11a4
    Faulting application start time: 0x01cd4d6c9eb8c6bf
    Faulting application path: C:\Program Files\Microsoft Data Protection Manager\DPM\bin\DPMRA.exe
    Faulting module path: C:\Windows\system32\KERNELBASE.dll
    Report Id: 07536bf5-b960-11e1-b34c-001f29e0a51e

    VSSadmin list writers on Hyper-v server

    Writer name: 'Microsoft Hyper-V VSS Writer'
       Writer Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
       Writer Instance Id: {5cbb253f-5400-4c89-a6e7-a7b78ae4087a}
       State: [5] Waiting for completion
       Last error: No error

    Any Ideas?

    Thank You


    • Edited by Rob Day Tuesday, June 19, 2012 12:12 AM removed FQDN
    Monday, June 18, 2012 6:56 PM

All replies

  • Is there any action in this forum of late?  should I post in the general forum?  When I setup DPM for the first time in '07, this forum solved many a problem for me.

    I have disabled Chimney stack. I had a dynamic disk on the test VM, which I converted to fixed, I have disabled windows firewall on DPM Server, hyper-v server and protected VM all to no avail.  I was able to create a protection group, but the initial replica creation failed.  It did however pass/finish a consistency check so I have one recovery point.  all other recovery points have failed with the same error on both the dpm server and the hyper-v server [see above].

    I would greatly appreciate any help!


    Thursday, June 21, 2012 4:37 PM
  • Hi,

    I don't see the correlation of enabling hyper-v on DPM server and the DPMRA crashes on the Hyper-v Host.

    It seems the DPMRA agent is crashing on the HyperV Host with an invalid parameter error code 0x80070057.  Unfortunalty, without looking at the crash dump, it is not possible to tell why it's crashing.  You can try looking in the C:\Program Files\Microsoft Data Protection Manager\DPM\Temp at the dpmra*.errlog.crash logs to see if there is more details.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Sunday, June 24, 2012 5:13 PM
  • Mike,

    Thanks for the reply! Unfortunately, we went through a domain rename this weekend that turned out to be a rough process.  Not doing my homework well enough, I realized I needed to start over with my DPM protection after the domain rename.  I figured as I was doing this, I would export all of my VM's and reinstall Server 2008 R2 on my Hyper-V server.  My old Hyper-v server was running server 2008 R2 but had been upgraded from server 2008.  I had read that others [very few] had a dpm/hyper-v issue with an upgraded OS.  So I went with a clean install and will be testing child partition snapshots soon.

    Thanks again


    Sunday, June 24, 2012 5:20 PM