locked
SSIS - Failed to create the task. (Microsoft Visual Studio) RRS feed

  • Question

  • I have created one Custom Task in SSIS. Basically I have one solution and 2 class library project one for Task and one for UserInterface

    when i try to drag new task from tool box it says following errror

    ===================================

    Failed to create the task. (Microsoft Visual Studio)

    ===================================

    The task editor of the type 'CustomErrorControl.CustomControlnew,CustomErrorControl,Version=1.0.0.0,Culture=Neutral,PublicKeyToken=  0c2b681d5171851e' is not installed correctly. (Microsoft.DataTransformationServices.Design)

    ------------------------------
    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%u00ae+Visual+Studio%u00ae+2005&ProdVer=8.0.50727.762&EvtSrc=Microsoft.DataTransformationServices.Design.SR&EvtID=TaskEditorNotProperlyInstalled&LinkId=20476

    ------------------------------
    Program Location:

       at Microsoft.DataTransformationServices.Design.DtrTaskDesigner.InitializeTaskUI()
       at Microsoft.DataTransformationServices.Design.DtrTaskDesigner.OnNewTaskAdded()
       at Microsoft.DataTransformationServices.Design.DtsBasePackageDesigner.CreateExecutable(String moniker, IDTSSequence container, String name)

     

    CustomErrorControl is my name space and CustomControlNew is my class name.

    does it TypeName should appear like what i have?

    I have unstalled it and try to reinstall it. change the stong name key and they try again but somehow same error..

    Please help..

    Wednesday, April 9, 2008 4:05 PM

All replies

  • Hello Everyone,

     

    anyone please reply..i really need help regarding above error.

    Thanks

     

     

    Thursday, April 10, 2008 3:09 PM
  • Hello Shahfromusa,

     

    In the error message, a few things "pop out" to me:

     

    1) The designer is looking for (based on your metadata) a class called "CustomErrorControl.CustomControlnew", but you say your class name is CustomControlNew (capital N) -- this might be an issue...

    2) You didn't mention the assembly name your metadata references, but it is looking for an assembly called "CustomErrorControl..." -- is that the name of the UI assmebly you're creating (not just the namespace name?)

    3) Did you (successfuly) GAC the UI using gacutil or by dragging the dll to \windows\assembly in Explorer?

     

    -David

     

     

    Tuesday, April 15, 2008 5:47 PM
  • Ends up that you just want to restart the SSIS service.  The GAC can get corrupted, and it will cause this error to occur.  At least, this solution fixed my problem with another data flow task that was giving the same error message.

     

    Cheers.

     

    beenhazed

    Monday, August 11, 2008 8:14 PM
  • David -

    Like anything else in windows, of couse it has to be properly registered! Just where is the tough part. I've been struggling with this for days, and the \windows\assembly solution worked like a charm. Drinks on me.

    Monday, January 24, 2011 6:51 PM