none
Adjust Router Advertisement?

    Question

  • Hello,

    I have a windows server 2012 R2 instance that I need to have announce a router advertisement, but the options present in the advertisement do not reflect the settings shown in `get-netipinterface "ethernet" -addressfamily ipv6 | fl`.

    I have 'Managed' and 'Other' flags set according to powershell, but when I capture the advertisement with message analyzer the M and O flags are both disabled.

    `get-netroute | fl` doesn't give any useful options.

    `RandomizeIdentifiers` is set to disabled under get-net-ipv6protocol, but again the autonomous flag is set on the actual advertisement.

    Any help would be greatly appreciated.


    Mediocre Access 2010 | (Baby) Beginner C Sharp | OK at Active Directory (2012 R2) | Fragmented understanding of DNS/DHCP | Laughable experience with Group Policy | Expert question asker on MSDN Forums


    • Edited by UpTide Friday, June 16, 2017 3:26 PM
    Friday, June 16, 2017 3:25 PM

All replies


  • Hi,

    Based my understanding, you configured  M and O flags both enabled, but when you use your message analyzer to found it disabled.

    >>I have 'Managed' and 'Other' flags set according to powershell, but when I capture the advertisement with message analyzer the M and O flags are both disabled.

    What is your message analyzer? Is it a third-party software?

    There is a related issue with you. I think it is helpful to you.

    https://social.technet.microsoft.com/Forums/en-US/31cb8998-c648-4f8e-8335-656007bad936/windows-server-2012-r2-ipv6-managedaddressdisabled-fail?forum=ipv6

    Please noted what em2slyn and Midnite__A  said.


    Best Regards,

    Frank


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 19, 2017 9:17 AM
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.
    Best Regards,
    Frank

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 21, 2017 5:39 AM
  • Hi,

    Was your issue resolved? 

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,
    Frank

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 28, 2017 9:22 AM