locked
BGinfo not running silently RRS feed

  • Question

  • BGinfo running at startup on Windows 7 workstations. Here's the command line

    C:\Windows\BGInfo.exe C:\Windows\Custom.bgi /timer:5 /silent /NOLICPROMPT

    I had to add in a 5 second delay to allow GPO to run first to force the standard background

    Problem is during the 5 seconds you see the DOS windows with the bginfo command line and also the bginfo customisation screen

    I had though /silent should suppress all this ??


    Ian Burnell, London (UK)

    Thursday, August 21, 2014 10:07 AM

Answers

  • Hi,

    How did you implement this? Via logon script or task schedule?

    The main issue is the timer:5, we need to set timer:0 in order to not display customisation screen, so regarding to the time delay to execute the application, please refer the following two solutions:

    If we use task schedule, then we can create a task with a delay at logon, like screenshot below

    If we use a logon script, such as execute a batch file, then we can insert a time delay into the batch file, many examples are on the internet.

    Regarding to the DOS windows with the bginfo command line, in a batch file, we usually begin with "@echo off" , this can prevent any of the commands in the batch file from being displayed, but if you're referring to a one second pop-up of cmd line, then, there're also hide solutions we can find like

    http://blogs.technet.com/b/heyscriptingguy/archive/2006/05/19/how-can-i-hide-the-command-window-when-executing-a-command-like-net-localgroup-administrators.aspx


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by Ian Burnell Monday, August 25, 2014 4:03 PM
    Monday, August 25, 2014 8:31 AM

All replies

  • Hi,

    Please see the command line options below:

    / Silent means "Don't report error", I tested in my machine, if we set the timer to a number (not zero), it specifies the timeout value for the countdown timer, in seconds.


    Yolanda Zhu
    TechNet Community Support

    Friday, August 22, 2014 3:02 AM
  • Indeed silent= don't report errors so question is how to run bginfo silently in the first place

    Ian Burnell, London (UK)

    Friday, August 22, 2014 7:10 AM
  • Hi,

    How did you implement this? Via logon script or task schedule?

    The main issue is the timer:5, we need to set timer:0 in order to not display customisation screen, so regarding to the time delay to execute the application, please refer the following two solutions:

    If we use task schedule, then we can create a task with a delay at logon, like screenshot below

    If we use a logon script, such as execute a batch file, then we can insert a time delay into the batch file, many examples are on the internet.

    Regarding to the DOS windows with the bginfo command line, in a batch file, we usually begin with "@echo off" , this can prevent any of the commands in the batch file from being displayed, but if you're referring to a one second pop-up of cmd line, then, there're also hide solutions we can find like

    http://blogs.technet.com/b/heyscriptingguy/archive/2006/05/19/how-can-i-hide-the-command-window-when-executing-a-command-like-net-localgroup-administrators.aspx


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by Ian Burnell Monday, August 25, 2014 4:03 PM
    Monday, August 25, 2014 8:31 AM
  • Thanks - I am just using a startup script so best thing is to put 5 second delay into the batch file and then run bginfo with /timer:0 to stop the pop-up

    I will test


    Ian Burnell, London (UK)

    Monday, August 25, 2014 4:03 PM