locked
ActiveX is installed only in administrative mode on IE9 but only recognized in user mode RRS feed

  • General discussion

  • I've developed an ActiveX component using .NET & C# (VS2010). I've also built a setup program for it using VS2010 Setup project and wrapped it in a cab.

    When I try to install the ActiveX (via test web page) it is installed only if running the browser in administrative mode ("Run As administrator"), but that installation is NOT recognized by the administrative mode browser. Only on the non-administrative mode browser the installation is recognized. When trying the test web page again on the administrative mode browser it asks again for permission to run the install. (I not sure, but may be on first test it was recognized on administrative mode browser, but not on non-administrative one).

    When I run the setup program directly (no via web page) I receive about the same results: the installation is recognized only while running the browser in non-administrative mode. The only difference is that when running the setup directly it prompts for elevated user rights, while when set is run via web page no prompt for elevated user rights is shown, and as said it only succeeds in administrative mode.

    All of this happens on 64bit Windows 7 machine with both 32bit and 64bit IE9. Also tried switch the browser to compatibility mode, or to IE7 mode/ IE7 standards and got the same results. All this PC are on WKGROUP network. Not on domain controlled network (no group policies applied).

    When I try all of this on XP machine (32bit) and IE8 the installation of the ActiveX is never recognized by a regular (non-administrative) user. I always try the installation via administrative user. Currently also in administrative user the installation is not recognized. I thinks it was recognized in some of the earlier test but now I cannot get it be recognized even on admin user (XP machine).

    My Qs are:

    1. Why ActiveX is not recognized by administrative mode browser?

    2. I can I make setup ask for elevated user rights when running via web page on non-administrative mode browser?

    Any help will be very appreciated.

    Thanks!




    Friday, December 21, 2012 12:09 AM

All replies

  • Hi,

    Tools>Internet Options>Security tab, click "reset all zones to default"

    Tools>ActiveX filtering.... ensure it is turned off for both admin and user accounts.

    you did not mention which Security zone your setup page loads in..(file>Properties to find out)..assuming Intranet..

    for questions about ActiveX development and setup please post to the IE Extension development forum. Thx for your understanding.


    Rob^_^

    Friday, December 21, 2012 12:20 AM
  • Hi Rob,

    Thanks very much for your reply.

    I'm currently testing my ActiveX setup on the Intranet zone, but I've also tried it with the same results on the Internet zone. I've also tried what you have suggested and reset my Intrant zone to default (this is where I'm running my tests), and made sure ActiveX Filtering is disabled, but still got the same results.

    I'll further post to IE Extensions Development.

    Thanks anyway for your reply.

    Friday, December 21, 2012 12:58 AM
  • Hi,

    thx for the feedback.... any chance of providing a link to your installation page? you may like to include it when you post to the Extension development forum...http://social.msdn.microsoft.com/Forums/en-US/ieextensiondevelopment/threads

    mmmm.... check the setting.... Advanced tab of Internet Options>uncheck (default) "Do not save encrypted files to disk" if you use the https protocol on your setup page.

    Regards.


    Rob^_^


    Friday, December 21, 2012 2:49 AM
  • Hi Rob,

    Thanks again for your reply.

    I'm not using https (just http), and on the advanced tab the "Do not save encrypted files to disk" is unchecked.
    Actually all the tests regarding Intranet Zone are done by the "web" server being on my local PC (using http://localhost..., and ASP.NET Development Server on my PC serving as the "web" server).

    But, as I'm preparing to send you the link to my ActiveX on the internet, I tried (again? I'm not sure) the ActiveX over the Internet and as with Intranet it can be installed only when running IE as administrator. However the over the internet the installation of the ActiveX is neither recognized when running browser as admin nor when running browser as non-admin, BUT it is recognized(!) when accessing the same web page from the Intranet (my localhost). When I say 'not recognized' I mean that when trying to refer to the ActiveX's properties or methods in my JavaScript code I get an error that these are not defined ("Object doesn't support property or method..." or value of 'undefined' for a property of the ActiveX). Currently when there is err with the ActiveX I present a msgbox saying "Please install ActiveX by running Browser as Administrator".

    I'm trying now to figure out why my Active can not be installed over the Internet.

    Anyway here is a link to my ActiveX: http://www.i-techcom.co.il/ActiveXTest2.html. Please note that my ActiveX is not signed and the only change to the default security settings of IE for the Internet Zone is that "Download unsigned ActiveX controls" should be marked 'prompt' (instead of 'disable').

    I can send source code (a small one) of my project, if you willing to take a look.

    Thanks,

    Itzik



    Friday, December 21, 2012 7:07 PM