locked
WSUS Connection Error RRS feed

  • Question

  • Hi Guys,

    unfortunately I deleted wsus content folder. Now wsus is not loading and throwing connection error. Is there any way to fix that. I don't want contents in wsus content folder but need to fix this error. Below is the error I found in event viewer

    The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists,

    Any help would be much appreciated.

    Sunday, July 3, 2016 9:55 AM

Answers

All replies

  • try this:

    At the command line %drive%\Program Files\Update Services\Tools>, type:

    wsusutil movecontent contentpath logfile -skipcopy

    https://technet.microsoft.com/en-au/library/cc720466(v=ws.10).aspx


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Sunday, July 3, 2016 10:14 AM
  • After doing what Don suggested, also run a wsusutil reset:

    reset

    Checks that every update metadata row in the database has corresponding update files stored in the file system. If update files are missing or have been corrupted, WSUS downloads the update files again.

    • After restoring the WSUS database.
    • When troubleshooting

    It will make sure, that all files are downloaded. This can take up to 4 hours.

    Best regards,

    Andrei


    We could change the world, if God would give us the source code.

    Sunday, July 3, 2016 6:49 PM
  • Hi Andrei,

    Thank you for your Support. I've resolved the issues with unstalling the WSUS Services then rebooting the Server and installing the WSUS again to associate it with my external database. Every Settings is back to where it was. Thank you once again.

    I used this link to install the WSUS.

    https://microspecialist.wordpress.com/2013/10/28/installing-wsus-on-server-2012-step-by-step/

    Best regards,

    Joseph

    • Marked as answer by Joseph.JJK Thursday, July 7, 2016 2:07 PM
    Thursday, July 7, 2016 2:07 PM
  • Hi Andrei,

    Thank you for your Support. I've resolved the issues with unstalling the WSUS Services then rebooting the Server and installing the WSUS again to associate it with my external database. Every Settings is back to where it was. Thank you once again.

    I used this link to install the WSUS.

    https://microspecialist.wordpress.com/2013/10/28/installing-wsus-on-server-2012-step-by-step/

    Best regards,

    Joseph


    That's a good guide, it doesn't mention that you should apply the various updates for WSUS to the server
    eg KB2919355, KB2938066, KB3095113, KB3159706 (manual steps required)

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Thursday, July 7, 2016 9:08 PM