locked
Account Password Bug when using English Version Software and French Keyboard RRS feed

  • Question

  • Possible bug in Windows 7. 

    Background - I recently did a clean install of Windows 7 in English, because my previous software was Vista in French. During install process I selected input as a "French Keyboard". Install went smoothly, no issues.

    Current situation - So, I now have a laptop running an English version of Windows 7 home premium. However my keyboard is French (AZERTY).

    Problem - Working in an account with admin privileges, if I change an User Password to something with exclusively French layout of keys, for example: "AZER" it accepts the change, but when you try to login using that same password it says it an incorrect password.

    However, if I change the password to something that has the same key layout on both French and English keyboards, for example: "ERTY" The password is accepted, and it works when you try to login.

    I suspect that the change password "routine" is forcing the input for the password into English i.e. when I type "AZER"  it's recorded as "QWER".  (Of course you can't see this, because you only see the Black Dots used to hide the password!)

    • Moved by Carey FrischMVP Friday, August 13, 2010 5:21 PM Moved to proper forum category (From:Windows 7 Miscellaneous)
    Friday, August 13, 2010 2:16 PM

Answers

  • The logon screen is running under a different context that your user session, so I suspect that the input locale is different for your user setting.

    Try switching locales using ALT + SHIFT. You should see the active locale indicated (e.g. "EN" or "FR") in the upper left corner of the logon screen.

    Another way to check the current locale is to use the On-screen keyboard. Click the Ease of Access button in the lower left corner and select "Type without a keyboard".  The layout of the on-screen keyboard should match the input locale.

    Hope this helps.

    • Proposed as answer by Cloud_TS Monday, August 16, 2010 9:20 AM
    • Marked as answer by Linda Yan Monday, August 23, 2010 8:43 AM
    Friday, August 13, 2010 6:40 PM

All replies

  • The logon screen is running under a different context that your user session, so I suspect that the input locale is different for your user setting.

    Try switching locales using ALT + SHIFT. You should see the active locale indicated (e.g. "EN" or "FR") in the upper left corner of the logon screen.

    Another way to check the current locale is to use the On-screen keyboard. Click the Ease of Access button in the lower left corner and select "Type without a keyboard".  The layout of the on-screen keyboard should match the input locale.

    Hope this helps.

    • Proposed as answer by Cloud_TS Monday, August 16, 2010 9:20 AM
    • Marked as answer by Linda Yan Monday, August 23, 2010 8:43 AM
    Friday, August 13, 2010 6:40 PM
  • You can also copy your international setting to the welcome screen and to new user accounts. For the Help and Support center:

    Open Region and Language (Control Panel --> Region and Language)

    Click the Administrative tab, and then click Copy settings.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

    Do one of the following:

    To copy the current settings to the default user account, select the New user accounts check box. The default account is used as a template for creating new user accounts. This setting allows administrators to set the default format, keyboard layout, and display language for new users. Any user account created on the computer after the settings have been copied to the default user account will have these settings applied. Existing user accounts aren't affected.

    To copy the current settings to the Welcome screen and other system accounts (local system, local service, and network service), select the Welcome screen and system accounts check box. The system accounts are special accounts used by Windows‌ services. This setting allows administrators to specify a display language and keyboard layout for the Welcome screen. It also sets the display language for users who haven't specified a display language.

     

    Friday, August 13, 2010 7:35 PM