none
Unable to install MIM 2016 Service and Portal - SharePoint Claims Issue RRS feed

  • Question

  • Hi,

    Have deployed SharePoint Foundation 2013 Sp1, and now am trying to install MIM 2016 Service and Portal and get the following error:

    "The FIM portal does not support being deployed on a SharePoint web application with claims-based authentication. Please make sure the SharePoint web application is configured with classic-mode authentication"

    According to another Microsoft article: "claims-based authentication is the default (in SharePoint Foundation 2013) and preferred method of user authentication". So why is MIM not following Microsoft best practices?

    It would be nice if the MIM documentation team would provide us with an answer in order to deploy and test their new product (or update MIM to work according to Microsoft best practices).

    Unfortunately this article does not really say enough: https://technet.microsoft.com/en-us/library/jj863242.aspx?f=255&MSPPError=-2147217396

    Look forward to hearing some feedback from the team.

    Regards,

    SK




    • Edited by Shim Kwan Thursday, August 6, 2015 3:44 AM
    Thursday, August 6, 2015 3:20 AM

All replies

  • Then looked at this: https://mohitvash.wordpress.com/2013/08/13/create-classic-mode-web-application-in-sharepoint-2013/

    After running the command, the warning pops up saying that "Windows Classic authenticationn is deprecated in this release and the behavior of this cmdlet is obsolete"

    Wow, really?

    Thursday, August 6, 2015 4:00 AM
  • Hi,

    Have deployed SharePoint Foundation 2013 Sp1, and now am trying to install MIM 2016 Service and Portal and get the following error:

    "The FIM portal does not support being deployed on a SharePoint web application with claims-based authentication. Please make sure the SharePoint web application is configured with classic-mode authentication"

    According to another Microsoft article: "claims-based authentication is the default (in SharePoint Foundation 2013) and preferred method of user authentication". So why is MIM not following Microsoft best practices?

    It would be nice if the MIM documentation team would provide us with an answer in order to deploy and test their new product (or update MIM to work according to Microsoft best practices).

    Unfortunately this article does not really say enough: https://technet.microsoft.com/en-us/library/jj863242.aspx?f=255&MSPPError=-2147217396

    Look forward to hearing some feedback from the team.

    Regards,

    SK




    This article is exactly what you need to do. You need to disable the Claims Authentication.  I would, If I had the option, install it on a SP 2010 version. Nothing has changed in MIM that FIM 2010 had, in terms of SP requirements. This has been the case before (Known issue with SP 2013). 


    Nosh Mernacaj, Identity Management Specialist

    Thursday, August 6, 2015 12:21 PM
  • Hi,

    Eventually got it working by following this article: https://technet.microsoft.com/en-us/library/Mt219039.aspx

    Cheers.

    Thursday, August 27, 2015 9:18 PM
  • Hi,

    Eventually got it working by following this article: https://technet.microsoft.com/en-us/library/Mt219039.aspx

    Cheers.

    That article seems to have been replaced with this:

    https://docs.microsoft.com/en-us/microsoft-identity-manager/deploy-use/prepare-server-sharepoint

    FYI, in my case I received this error on a fresh install of MIM 2016 due to the default http://localhost site collection value. I needed to change it, as discussed here: http://www.fimspecialist.com/fim-r2-sp1-fim-service-and-portal-setup-wizard-ended-prematurely/


    Mike Crowley | MVP
    My Blog -- Baseline Technologies

    Tuesday, July 5, 2016 9:22 PM