locked
Windows 10 / Outlook 2013 indexing complete but no results? RRS feed

  • Question

  • I'd like to make a reference to this thread Outlook Indexing Problem

    Which I had in Windows 8.1 with Office 2010.

    In this instance I'm working on my girlfriends computer which has Windows 10 / Outlook / Office 2013. Often when searching in Outlook I'm getting the message "Search results might me incomplete because items are being indexed". I've closed Outlook and gone to Indexing Options and rebuilt indexes, come back a few hours later and it says "Indexing Complete" but when I go into Outlook I still get the message "Search results might me incomplete because items are being indexed" and very few or no results come up; if I go back into Index Options it says "Indexing in progress" when several minutes before it said it was completed?

    As per suggestions from the previous thread, I've run scanpst on the Outlook datafile until it says "Minor inconsistency's were found" but the repair button doesn't appear and an Ok button is the only option. I've also compacted the Outlook datafile and I'm still having issues were I can't search Outlook and alternately Indexing says completed before entering Outlook but goes back to "Indexing In progress" when I go into Outlook and I get almost no search results.

    How can I fix this?

    Saturday, April 14, 2018 9:47 PM

Answers

  • I tried setting Outlook offline and then created a new pst file and set it as the default data file. Then I imported all the data from the old file; ran ScanPst a couple times until there were no errors; I removed the old Pst file from the list of data files. It took another day for reindexing on the new pst file but after that search seems to work fine now.
    • Proposed as answer by FrancescoCZY Saturday, April 21, 2018 6:28 PM
    • Marked as answer by NormAtHome Wednesday, April 25, 2018 2:58 PM
    Friday, April 20, 2018 2:59 PM

All replies

  • Hi,

    What's your account type? Exchange, POP3 or IMAP account?

    For Exchange account, do you have cached Exchange mode enabled?

    What's the detailed version of both Outlook 2013 and Windows 10? According to my research, this error message could be related with Windows update. You could scroll down to check the details under Outlook known issues in the June 2017 security updates from this link and see if this is the case for you.

    "Something went wrong..." or "Search results may be incomplete" error when searching in Outlook [FIXED]

    Besides, recently, there is a known issue that No search results for POP/IMAP accounts. Please see the information in that link.

    If issue persists, in case there was a corrupted profile, please test this issue in a new profile to see the result.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 16, 2018 5:33 AM
  • Hi Perry:

    Outlook is setup using Pop / SMTP, at far as I know (because I checked Windows update multiple times) the version of Windows 10 is build 1709 and all updates are applied to Outlook 2013.

    I'm not at my girlfriends now and she's working tonight so I can't get on her computer by remote, I'll have to get that for you later and post back.

    I looked at the link you gave me and I only see "Outlook search returns no search results for POP and IMAP accounts." that is not the issue here as I'm getting partial search results, Indexing alternately says "Completed" but then when you go into Outlook it goes back to "Indexing in progress" (possibly because of new items in the inbox) but still when searching for things from the last say five years I should get more results than I do and I get the message at the top of Outlook "Search results might me incomplete because items are being indexed". So I don't know if that's referring to new items or old items are still being indexed even though it previously said "Indexing Complete".

    Tuesday, April 17, 2018 11:55 PM
  • Hi,

    Thank you for your update.

    In addition to a new profile, we could also try opening Outlook in safe mode to see if the issue continues. Please exit Outlook, press Win key + R to open the Run command, type outlook.exe /safe and then press Enter. 

    What's more, we could see if Outlook data is included in the indexing location. Please go to Control Pane > Indexing Options. If Microsoft Office Outlook is not listed, please select Modify, and then click to enable the check box next to Outlook.

    Here is an official article for your reference.

    Please feel free to post back with updates. We are willing to help.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    • Edited by Perry-Pan Wednesday, April 18, 2018 7:40 AM
    • Proposed as answer by Perry-Pan Thursday, April 19, 2018 8:10 AM
    Wednesday, April 18, 2018 1:40 AM
  • Hi there, 

    I have the same problem with Outlook under Win 10. Re-Indexing and including Outlook in the index didn't help. However in safe mode, Outlook is getting search results (in normal mode I get no results at all). So you are saying this is a Windows problem then? What can I do?


    Wednesday, April 18, 2018 7:25 AM
  • Hi,

    Are there any updates with this issue?

    Just to check whether the above information is helpful to you.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, April 19, 2018 8:10 AM
  • I tried setting Outlook offline and then created a new pst file and set it as the default data file. Then I imported all the data from the old file; ran ScanPst a couple times until there were no errors; I removed the old Pst file from the list of data files. It took another day for reindexing on the new pst file but after that search seems to work fine now.
    • Proposed as answer by FrancescoCZY Saturday, April 21, 2018 6:28 PM
    • Marked as answer by NormAtHome Wednesday, April 25, 2018 2:58 PM
    Friday, April 20, 2018 2:59 PM
  • Hi,

    So glad to see that this issue has been fixed. Thank you for sharing here.

    By the way, would you mind marking your reply as answer so that this case could be closed. In doing so, it will also benefit all community members who are facing similar issues.

    Thank you for your understanding and support. Have a nice day.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Sunday, April 22, 2018 1:01 AM
  • Hi,

    First, I'd like to wish you a nice day.

    Besides, it will be much appreciated if you could mark your reply as answer so that other users can easily find the useful reply here.

    Thank you for your understanding and support.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, April 24, 2018 7:11 AM