locked
Vista ulti 32b - black screen w mouse before login, after using vista drive as external drive RRS feed

  • Question

  • Hi all,

    About 10 days ago my cpu fan in my laptop starting make noises so I had to replace it. Today I received the fan and installed it, but when booting I get a black screen with just the mouse when the login is supposed to appear.

    So let me explain what exactly happened in those 10 days.

    I have got two drives for the laptop: one original Seagate drive that came with the laptop with dual boot XP Pro and Vista Ulti, and another larger (replacement) WD drive I bought 2 years ago and am running Vista Ulti on for the past 2 years. So when my CPU fan died I decided not to mainly use my laptop, but my desktop instead with W7 Ulti 64b. In the mean time I did want to gain access to my files on the laptop drive so I hooked it up as an external usb drive to my desktop. Obviously there were some security problems, because windows 7 couldn't get access to the vista drive. I solved this by adding access rights (permissions) so I could access almost all files and folders.

    So no I replaced the cpu fan and it works fine, but when I try to use the Vista drive in the laptop I get stuck with a black screen w mouse where the login screen is supposed to show. I have waited for about an hour, while I can hear the hard drive working (the heads are obviously moving) nothing else happens.

    Basically my question is how to fix this? Should I give Vista more time to 'work things out' and be patient until the login screen appears? (Usually it takes about 10-15 seconds until the login screen appears) I have tried to remove the permissions I have added for the drive using my desktop but can't figure out how to remove these. I am afraid I have messed something up with these permissions so now Vista can't boot up properly. I also ran system repair with my Vista DVD, but it says it couldn't find any errors and that boot status indicates that the OS booted sucessfully. Error code is always 0x0

    FYI: I have experienced a lot problems with this particular hard drive in the past (a lot of BSOD's after booting, even after a proper shutdown and spontaneously doesn't occur a next time booting)  so I know something is wrong with the drive and already bought one to replace this one and will put W7 on it. Now I just want to gain full access again to this drive by logging in and copy over the files I couldn't access through my desktop. I tried booting up in safe mode, but the exact same black screen and only the mouse pointer appear. I haven't added any new hardware, and no hardware is connected.

    Any help is appreciated! thanks!

    EDIT: it's probably nothing with the permission. I hooked the drive up again to my desktop, and the permision were set back again to the standard SYSTEM and my username with no permissions. So I guess Vista set its permissions back to its original settings when booting. So the problem is something else.

    EDIT: I did  Long Generic test with SeaTools and it figured I had a lot of Bad LBA's. Probably hundreds of them, so this may cuse Vista can't boot as it is unable to access some of those bad sectors that it needs

    Tuesday, July 27, 2010 6:08 PM