none
Windows 7 Screensaver GPO

    Question

  • I know there are several questions like this, I checked those first but am still having a problem.

    Using a windows 2008 domain, I want to force windows 7 pcs to lock with the screensaver.

    I have Four settings set:
    Force specific screen saver - Enabled, scrnsave.scr
    Password Protect the screen saver - Enabled
    Prevent changing screen saver - Enabled
    Screen saver timeout - 900 seconds

    I have proven to myself, that the policy is getting to the pcs in question. the behavior I am getting however is as follows.

    If I right click on the desktop and go to personalize, the screen saver on the bottom right is greyed out, and says none. Screen saver will never go on.
    If I turn the third policy, Prevent changing screen saver to disabled, I can see the settings the screen saver is using. The settings it has are correct, but the screensaver never starts. It still always says screen  saver - none, where it should say screensaver - blank.

    If I take away the policy above completely, then manually change the screen saver to blank instead of none that windows 7 has as default. then if I reapply the policy the pc will lock as expected with the correct timeout and password requirements(except in the rare wireless mouse problem pc) And when you go to personalize from the desktop the screen saver says blank.

    Is there any way anyone can think of to fix this problem so I don't have to go visit all these machines?

    Friday, June 05, 2015 7:55 PM

Answers

  • Hi,

    How is it going? Based on the description, we can try to log off and log on again to see if it helps. If the situation persist, we may try an alternate screensaver file to see if it works out.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, June 17, 2015 8:58 AM
    Moderator

All replies

  • "Enable screen saver" = Enabled  :)

    Here's a guide:
    http://prajwaldesai.com/lock-computers-in-domain-via-group-policy/


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)



    • Edited by DonPick Friday, June 05, 2015 11:25 PM
    Friday, June 05, 2015 11:18 PM
  • Unfortunately, that doesn't work either, still says Screen Saver - None
    Monday, June 08, 2015 7:24 PM
  • I believe your issue may revolve around specifying the screen saver "Force specific screen saver - Enabled, scrnsave.scr" which is blank.
    Monday, June 08, 2015 7:28 PM
  • Are you Saying I have an improper setting to force users to use the "blank" screensaver with password?

    This is what I see with the policy applied.

    Monday, June 08, 2015 7:56 PM
  • Hi,

    How is it going? Based on the description, we can try to log off and log on again to see if it helps. If the situation persist, we may try an alternate screensaver file to see if it works out.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, June 17, 2015 8:58 AM
    Moderator