none
How to add a person in HealthVault on the iPhone RRS feed

  • Question

  • Hello, I have a person which is permitted to see me health information in HealthVault online and that works. But when we are trying to view the same in the iPhone app, it shows the person dimmed and that there is no permission, which cannot be as there is permission to see the same on the web. What do I need to do?
    Saturday, February 2, 2013 10:33 AM

All replies

    • For applications, like the iPhone app, you can only authorize a person that has enough permissions to use the application.  For example, if you permitted a person to see your record but did not allow them to edit any information and an application requires edit permissions, then the record will not be able to be used for that application.

      So in this situation when you are using the iPhone app, and you notice a record is dimmed, that means that there is not enough permissions for that record to be able to use it in the application.

      If you would like to use that record for your application, you should contact the person who shared you that record and ask for more permissions.

    Sunday, February 3, 2013 1:12 AM
  • The answer provided seems obvious, but it's not really...  I have a record, and I set up a separate records for family members.  From the family member's account, I set myself up as a custodian, which means I should have full access.  And I've confirmed this on the website.

    And yet, when I try to access these custodian records on the iPhone app under my record, they remain dimmed and unselectable, as the original poster indicated.  On the full site, I can see everything for both records, so I can at least confirm there that custodian access is set up.  But it doesn't seem to work with the iPhone app...

    Is this a bug or deficiency with the iPhone app, in not being able to view other's records to which full custodian access has been granted?  Or are there other steps that need to be taken to get these shared records to appear in iPhone app?

    Saturday, February 9, 2013 9:14 PM
  • Corey, are you seeing these records "dimmed and unselectable" when you go to the page where you select records to authorize for the iPhone app? (The top of this page says "Allow access"; you can get to this page by clicking the + icon on the "Your records" page in the iPhone app.) If so, there should be a message next to the record that explains why it is unselectable. Can you write back and tell me what that message says?

    If it says, "You don't have enough permission" next to the record, can you do one other thing, please? Can you sign in to your HealthVault account on the web and under the record name, click "Switch person" and then click "See all." Confirm that each record says "Access: Custodian."

    Or, have you successfully allowed the iPhone app to access these records, but then they are "dimmed and unselectable" on the "Your records" page in the app?

    If you could go to the trouble of providing that information, it would help track down a solution for you. I'm able to use a shared record in my HealthVault iPhone app, so I *think* it's not a bug or limitation with the app.

    Thnks,

    Kathy

    Thursday, February 14, 2013 12:27 AM
  • Kathy,

    Thanks for the quick reply.  Unfortunately, I wasn't able to get back to this so quickly.

    "Dimmed and unselectable" is indeed on the "Allow access" page on the iPhone app.  From the main page - "Your records" - I use the "+" button to add a user.  On the next page, I use the "Sign in" button under "Already have a HealthVault account?".  Then on the "Sign in to HealthVault" page, I enter the email/password that I set up for my Mom and press "Sign in" button.  This gets me to the "Allow access" page (which I can access immediately later from the "Your records" page using the "+" button, where I can see a grayed out and unselectable check-box, next to a gray "person" image, next to her name, under which is says "Already authorized" - again, all grayed out.  There is an "+ Add a person" button, but this attempts to add a new person under my account, which isn't what I want to do here.  The only button that is selectable here is "Cancel".

    I have confirmed numerous times, I do indeed have "Custodian" access.

    ...

    RESOLVED, BUT UNEXPLAINED...

    I thought that maybe there was a limit to the number of iPhone app instances to which an account has been linked.  My Mom also has an iPhone, and I set HealthVault up for her account there successfully.  As a test, I just disconnected record from my iPhone app, and tried connecting only hers.  This was successful, so apparently an account can be linked to multiple app instances.

    I noticed a few bugs along the way trying this.  First, after successfully disconnecting my account linking my Mom's, in the iPhone app then I tried disconnecting her account so I could re-connect mine.  The app said it successfully disconnected her account, but then when I went to connect mine, it took me directly to the confirmation page for her account, skipping the create an account/sign in page entirely, as if I had selected sign in and entered her login/password.  This was odd - I had disconnected her record, but was not able to login to connect mine.  I confirmed this twice before manually killing the app on my iPhone.  When I restarted it, I was then able to enter my own login details to re-connect my account.

    More curiously, after I re-entered my login details again, it asked me which records to add - it including my own, plus my wife's and my Mom's.  And it allowed me to select all three.  So now I have all of them visible through the app.

    But there are definitely some bugs.  I did try this a few times before I originally posted - that is, disconnecting my account and re-connecting it - without the App presenting all three records to me to select and manage.  But I did not try manually killing the app as part of these attempt.  I can only guess is that killing and re-starting the app cleared up whatever was causing it to not present me with the records other than my own.

    I don't know if there is any debug/log data that can be pulled from my my account, or from the app on my phone, but if there is, I'd be happy to provide it.  Again, the issue appears to be resolved, but I think only because I disconnected my record, killed and restarted the app and re-connected record again.

    Thanks,

    Corey

    Friday, March 1, 2013 1:38 PM