locked
Sequence Application with compatibility Windows XP SP3 RRS feed

  • Question

  • Hello,

    We have an application that runs only with compatibility for Windows XP SP3. When I Sequence this application and mark it on the sequence client with XP SP3, this setting is not saved in the package.

    The only solution is to mark the application as XP SP3 on the cliënt-pc's. But you understand, change the compatibility settings on every client is not the best solution.

    How can I mark the sequenced application to run with XP SP3 in the package?

    We have only Windows 7 cliënts.

     

    Thanks


    • Edited by FrankjJ91 Tuesday, November 15, 2011 1:10 PM
    Tuesday, November 15, 2011 1:09 PM

Answers

  • Thanks all for your help.

     

    I've found the problem. It was totally a different problem. The error: 1B401F2C-000002E4 means that the program has not full access to a file or folder. So I've installed the program without the sequencer enabled (stand alone) and I saw that the NTFS rights on the program folder was set to Everyone full access. When I delete the user Everyone, the program didn't work. 

    The second thing was the Q:\ drive. The program must be installed on the C:\Program Files (x86)\ folder to work fine with the NTFS permissions.

    And you must mark the setting "Enforce Security Descriptors" in the deployment tab when you edited the package.

     

    Now it's working, without errors or permission errors.

    • Marked as answer by FrankjJ91 Monday, November 21, 2011 11:47 AM
    Monday, November 21, 2011 11:47 AM

All replies

  • Hello,

    See these pages;

    http://blog.stealthpuppy.com/deployment/app-v-faq-8-can-i-use-application-compatibility-shims-with-app-v/

    http://blog.gridmetric.com/2011/10/17/how-to-set-windows-compatibility-settings-for-app-v-package-the-easy-way/


    /Znack

    Thanks. I've followed your second link that was the solution.
    Now, when I run the application, I got error: 1B401F2C-000002E4

    When I run the application as Administrator, it works fine so I Googled for my problem to edit the .OSD file, to make the application runs always as Administrator. I've followed this howto:
    http://blog.stealthpuppy.com/virtualisation/sequencing-the-app-v-management-console/ (the howto below the page), but this didn't work. I got the same error as therefore.

    My .OSD file:

    <?xml version="1.0" standalone="no"?>
    <SOFTPKG GUID="B49A49B9-1062-484C-9344-AE521EE4D6C0" NAME="LabSim" VERSION="1.0.0.0">
    	<IMPLEMENTATION>
    		<CODEBASE HREF="RTSPS://WAPP1.ICTLYCEUM.LOCAL:322/APlus/APlus_8.sft" GUID="DA564AC7-7995-411F-BFD4-7E9032B14D32" PARAMETERS="" 
    
    FILENAME="APlus\Orbis\OrbisStartup.exe" SYSGUARDFILE="APlus\osguard.cp" SIZE="44969267"/>
    		<VIRTUALENV TERMINATECHILDREN="FALSE">
    			<POLICIES>
    				<LOCAL_INTERACTION_ALLOWED>FALSE</LOCAL_INTERACTION_ALLOWED>
    			</POLICIES>
    		
    <ENVLIST>
     
    <ENVIRONMENT VARIABLE="__COMPAT_LAYER">RunAsInvoker</ENVIRONMENT>
     
    </ENVLIST>
    
    		</VIRTUALENV>
    		<WORKINGDIR>%SFT_MNT%\APlus\Orbis\</WORKINGDIR>
    		<VM VALUE="Win32">
    			<SUBSYSTEM VALUE="windows"/>
    		</VM>
    		<OS VALUE="Win764"/>
    	</IMPLEMENTATION>
    	<DEPENDENCY>
    		<CLIENTVERSION VERSION="4.6.0.0"/>
    		<SCRIPT EVENT="LAUNCH" TIMING="PRE" WAIT="TRUE" PROTECT="FALSE">
    			<HREF>REG.EXE ADD "HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /v "Q:\APlus\Orbis\OrbisStartup.exe" /t 
    
    REG_SZ /d "WINXPSP3"</HREF>
    		</SCRIPT>
    	</DEPENDENCY>
    	<PACKAGE NAME="APlus"/>
    	<ABSTRACT/>
    	<MGMT_SHORTCUTLIST>
    		<SHORTCUT LOCATION="%CSIDL_DESKTOPDIRECTORY%" FILENAME="LabSim.lnk" OVERRIDDEN="FALSE" DISPLAY="LabSim" ICON="%SFT_MIME_SOURCE%/APlus 
    
    Icons/LabSim 1.0.0.0.ico"/>
    		<SHORTCUT LOCATION="%CSIDL_PROGRAMS%" FILENAME="LabSim.lnk" OVERRIDDEN="FALSE" DISPLAY="LabSim" ICON="%SFT_MIME_SOURCE%/APlus Icons/LabSim 
    
    1.0.0.0.ico"/>
    	</MGMT_SHORTCUTLIST>
    	<MGMT_FILEASSOCIATIONS>
    		<PROGIDLIST/>
    		<FILEEXTENSIONLIST/>
    	</MGMT_FILEASSOCIATIONS>
    </SOFTPKG>
    
    
    

    Lines added:

    <ENVLIST>
    <ENVIRONMENT VARIABLE="__COMPAT_LAYER">RunAsInvoker</ENVIRONMENT>
    </ENVLIST>


    Is there a fault in this script, or is something different wrong?

    Thanks


    Wednesday, November 16, 2011 12:23 PM
  • In your XML listing above, the command looks like it has an extra line. Does it look like this:

    REG.EXE ADD "HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /v "Q:\APlus\Orbis\OrbisStartup.exe" /t REG_SZ /d "WINXPSP3"

    if you run command prompt inside the virtual application, does the __COMPAT_LAYER variable exist and does the registry value above also exist?


    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Wednesday, November 16, 2011 12:51 PM
    Moderator
  • There's a problem with the copy-paste result to this forum. In the real .XML file, there aren't extra lines.

    If I run this script in the virtual environment, the line was added to the cliënt registery and the program was configured to run as XPSP3 compatibility.

    The only thing is the error when starting the program: 1B401F2C-000002E4.
    When I start the same virtual application as administrator (this is sfttray.exe), it works fine and the application started.

    But also when I modified the first line, to this:
    "Q:\APlus\Orbis\OrbisStartup.exe" /t REG_SZ /d "WINXPSP3 RUNASADMIN"
    It's not working.

    It only works when C:\Program Files (x86)\Microsoft Application Virtualization Client\stttray.exe was run as Administrator. Is this the correct solution to solve my problem, or is this not secure?

     

    Thanks

    Friday, November 18, 2011 8:55 AM
  • Does the application consist of more than one executable? If it's more than OrbisStartup.exe, you may have to set it for each exe

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Friday, November 18, 2011 9:55 AM
    Moderator
  • There's a problem with the copy-paste result to this forum. In the real .XML file, there aren't extra lines.

    If I run this script in the virtual environment, the line was added to the cliënt registery and the program was configured to run as XPSP3 compatibility.

    The only thing is the error when starting the program: 1B401F2C-000002E4.
    When I start the same virtual application as administrator (this is sfttray.exe), it works fine and the application started.

    But also when I modified the first line, to this:
    "Q:\APlus\Orbis\OrbisStartup.exe" /t REG_SZ /d "WINXPSP3 RUNASADMIN"
    It's not working.

    It only works when C:\Program Files (x86)\Microsoft Application Virtualization Client\stttray.exe was run as Administrator. Is this the correct solution to solve my problem, or is this not secure?

    I think this may be the same problem I have run into (don't remember the exact error message, but sounds like it) when using XPSP3 compat mode in the manner I described in my blog article. The resolution, apart from making all users admin which was no-go, was to use VISTARTM as a compatiblity mode for that application (LiveLink).

    It enabled the application to start in Win7, like XPSP3, so the problem was avoided. You could perhaps try other XP alternatives as well, if they avoid the error.

     


    br,
    Kalle Saunamäki
    http://blog.gridmetric.com/
    Sunday, November 20, 2011 9:09 PM
    Moderator
  • Thanks all for your help.

     

    I've found the problem. It was totally a different problem. The error: 1B401F2C-000002E4 means that the program has not full access to a file or folder. So I've installed the program without the sequencer enabled (stand alone) and I saw that the NTFS rights on the program folder was set to Everyone full access. When I delete the user Everyone, the program didn't work. 

    The second thing was the Q:\ drive. The program must be installed on the C:\Program Files (x86)\ folder to work fine with the NTFS permissions.

    And you must mark the setting "Enforce Security Descriptors" in the deployment tab when you edited the package.

     

    Now it's working, without errors or permission errors.

    • Marked as answer by FrankjJ91 Monday, November 21, 2011 11:47 AM
    Monday, November 21, 2011 11:47 AM