locked
Test notification MP errors RRS feed

  • Question

  • I am following steps in http://support.microsoft.com/kb/934756 to create test task for notification but I am getting the error below when I run the task. Any suggestions? Cannot find task definition in local management packs Error Code: -2130771899 (Unknown error (0x80ff0045))
    Friday, April 8, 2011 5:08 PM

Answers

  • If discoveries are not working in your MP (if you only created rules and tasks, you may need to create classes and discoveries) - then you won't get any behavior at all.

    Since you are getting an error, could you post some details on what you are getting?  And perhaps post what you feel are relevant items from your management pack?


    Microsoft Corporation
    • Marked as answer by Vivian Xing Friday, April 15, 2011 8:21 AM
    • Unmarked as answer by Victag Friday, April 15, 2011 4:33 PM
    • Marked as answer by Bob CornelissenMVP Tuesday, September 27, 2011 10:54 AM
    Wednesday, April 13, 2011 7:51 PM

All replies

  • Hello, did you use the same management pack in step 1 and 2 for instance?

    Otherwise could you provide a bit more information please?


    Bob Cornelissen - BICTT (My BICTT Blog)
    Monday, April 11, 2011 7:58 AM
  • You probably just have to wait until the new tast is being replicated to the agent.
    Regards,
    Marc Klaver
    http://jama00.wordpress.com/
    Monday, April 11, 2011 8:10 AM
  • Also, you can look at the notification test tool

     

    http://blogs.technet.com/b/momteam/archive/2009/05/19/notifications-test-tool.aspx


    Rob Kuehfus | System Center Operations Manager | Setup and Deployment Program Manager
    Tuesday, April 12, 2011 2:47 PM
  • I used same management pack ( a custom one just for this ) to store both the task and the rule.  I have waited days and am sure it has replciated to agents, though I am testing on the RMS which would have gotten it immediately.  I prefer to stick to using the KB test notification since it works great on my other SCOM environments, just not this one particular environment for some strange reason.  Is there no way to troubleshoot this error?
    Wednesday, April 13, 2011 5:57 PM
  • If discoveries are not working in your MP (if you only created rules and tasks, you may need to create classes and discoveries) - then you won't get any behavior at all.

    Since you are getting an error, could you post some details on what you are getting?  And perhaps post what you feel are relevant items from your management pack?


    Microsoft Corporation
    • Marked as answer by Vivian Xing Friday, April 15, 2011 8:21 AM
    • Unmarked as answer by Victag Friday, April 15, 2011 4:33 PM
    • Marked as answer by Bob CornelissenMVP Tuesday, September 27, 2011 10:54 AM
    Wednesday, April 13, 2011 7:51 PM
  • There is nothing in the MP I have created other than the 1 task and 1 rule mentioned in the KB article for testing notification.  I have used this same KB in other SCOM environments I support without any issues and did not need to create classes.  I have targeted the rule and class to the "Windows Computer" class as the KB suggests.  There is no other error other than what I posted in the original explanation.
    Friday, April 15, 2011 4:33 PM
  • Hi,

    Can you export the MP and verify that the task definition is as expected?

    Thanks,

    Shreedevi


    This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm
    Wednesday, April 20, 2011 5:38 AM
  • Hello, could you let us know if this question is answered or if you have found a solution?
    --------------------------------------------------------------------------------
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    Sunday, September 18, 2011 10:09 AM
  • Hello. No activity for over 30 days. Will mark as answer. Feel free to re-open. Thanks
    --------------------------------------------------------------------------------
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Bob Cornelissen - BICTT (My BICTT Blog) - Microsoft Community Contributor 2011 Recipient
    Tuesday, September 27, 2011 10:53 AM