locked
Favorites issue in IE 7 on vista RRS feed

  • Question

  • i wanted to see if anyone else to could test the error i am recieving, i copied my favorites over from another machine (XP) just doing a copy and paste of the favorites folder, my favorites are there and work but i cannot add new favorites to folders that were moved from the XP machine, i think it has something to do with permissions not being applied to those folders that came from XP cause i can create new folders in favorites and add webpages there. i already submitted a bug report but wanted to see if anyone else had seen this issue or could recreated it

    Sunday, June 18, 2006 3:02 AM

Answers

  • Ack. that figures.

    Well... Perhaps it might be a simple fix.

    If you can create new folders - and those folders allow you to add new shortcuts - how's this sound for a solution:

    1.) create a new folder with a name similar to one you've currently got - i.e. Links - > Links2

    2.) copy the shortcuts in the original Links tree to Links2

    3.) Delete the original, empty Links

    4.) Rename the Links2 to Links

    5.) Next folder. Repeat until done.

    Ok.. It's an UGLY solution. But it should fix it.

    And be sure to report this scenario using the beta reporting tool. Maybe the folks @ MS can fix it.

    Also... If memory serves - when I installed Vista on this box a couple of weeks ago, there was some sort of tool included with Vista that was supposed to be used to copy settings from your old computer to the new install. I didn't use it as I didn't see an immediate need. Guess that might have been somewhat useful in this case.

    Tuesday, June 20, 2006 12:26 AM

All replies

  • It can very easily be a permissions issue. I've seen where a changed log in for a network almost lost someone's Outlook files.

    Basically folders have an owner. When you log into machine X with any account, XP will create folders with you as the owner. Now, let's say, you're giving the laptop to a coworker or subordinate. This person's not yet set up on the network as a domain user, (or in the case I dealt with there was no one around to set new people up, so the new person used the same log in the previous owner of the laptop used). When I got there and set up new users, the new person couldn't access her old Outlook files - why? Because the old user was still the owner. Had to bump the new user up to Admin level permissions, then go to the folder and the files inside and take ownership of them all and then drop the user back down to "normal" access levels.

    You might try going in and taking ownership of those folders from yourself. Sounds silly, but the XP account is a different account from the one in Vista. They may be named the same, have the same rights, but underneath it all, Windows assigns a unique identifier to each and every account. If you delete say, user FRED from a computer, and you recreate a new user FRED on the same computer - those two accounts will considered entirely different - even if you give new Fred the same password, access rights, etc... as the old Fred.

     

    Monday, June 19, 2006 12:14 AM
  • i did take ownership of the folders again, still same error though...
    Monday, June 19, 2006 4:37 AM
  • Ok.. I copied the Favorite's folder from my XP box over to a shared folder on my Vista box. I then copied a few folders from the Favorites folder in the shared directory to the Favorites folder under Users and my user name. I opened up a copy of IE 7 and clicked the little star icon to make sure the folder got copied. It was right where it should have been. I then added a new web site to the folder - and I had no problems. It got created like a champ.

    Exactly how did you copy said Favorites folders over?

    Monday, June 19, 2006 5:19 AM
  • ok here is what i did,

    1. orginally i have sent the folder of favorites in a rar file to my machine at work, i copied that rar file down to my vista machine and just pasted it over the favorites folder there.

    2. Tried adding shortcuts to the folders that were copied over get the access error.

     

    Tonight i am going to wipe out the folders in favorites and try to copy them back in again. See if i can recreate the issue

    Monday, June 19, 2006 3:51 PM
  • Hmmm...

    Doubt WinRAR would do anything to a folder that would corrupt it or change it's properties.... BUT...

    Now, when you say you pasted over the favorites folder.. Did you completely overwrite the ENTIRE Favorites folder - or did you just dump the contents into the folder?

    There may be some issue here with overwriting the root Favorites folder. The Favorites folder in Windows is a special folder that has some properties given to it that other folders don't get.

    Monday, June 19, 2006 7:48 PM
  • that is what i was thinking :) overwriting the folder is never good but i know many people who migrate all their information by just copying and pasting everything from their profile to a new profile.

     

    to better anwser you yes i did overwrite the whole "favorites" folder with the folder from my Xp machine, i will restate that only to folders that i moved from the XP machine have this issue while the new folders i have created work fine. It is also amusing to note while i cannot create files there. i can create them in another folder that wasn't migrated over and then copy them to the pre-vista folder and they work without issues...ahh i  love troubleshooting..

    Monday, June 19, 2006 9:06 PM
  • Ack. that figures.

    Well... Perhaps it might be a simple fix.

    If you can create new folders - and those folders allow you to add new shortcuts - how's this sound for a solution:

    1.) create a new folder with a name similar to one you've currently got - i.e. Links - > Links2

    2.) copy the shortcuts in the original Links tree to Links2

    3.) Delete the original, empty Links

    4.) Rename the Links2 to Links

    5.) Next folder. Repeat until done.

    Ok.. It's an UGLY solution. But it should fix it.

    And be sure to report this scenario using the beta reporting tool. Maybe the folks @ MS can fix it.

    Also... If memory serves - when I installed Vista on this box a couple of weeks ago, there was some sort of tool included with Vista that was supposed to be used to copy settings from your old computer to the new install. I didn't use it as I didn't see an immediate need. Guess that might have been somewhat useful in this case.

    Tuesday, June 20, 2006 12:26 AM
  • yup they are already got a bug report about it :) and those are the steps i went through last night to "correct" the issue. I think from now on i'll just use the handy import/export wizard in IE, and yes the migration tool from vista would have saved me some of this hassle i bet if i hadn't done a clean install, ah well.  Thanks for the help none the less, at least it is working now
    Tuesday, June 20, 2006 3:30 AM
  • Here's a better way I found in IE7 on Vista. Start IE7 and choose to Import te favorites. You can point it to the Favorites folder of your old/backup copy and it will correctly import them into Vista.

     

    MK

    Tuesday, June 20, 2006 2:59 PM
  • I just add the new link to the main favourites folder and then drag it into the subfolder where I want it to be
    Tuesday, September 5, 2006 7:41 PM
  • I am also having this issue with my Favorites.  In my case, I decided to upgrade from XP where I had my partitions set up like such:

    • C: (operating system and apps)
    • D: (page file)
    • E: (data)

    I exported my IE 6 favorites to my E: partition.  When I upgraded i formatted the C: partition and installed Vista which of course left my E: partition alone. 

    I found in Vista you are able to change the location of a user's Documents, Favorites, Links, Photographs, etc. folders by changing the "Location" property for a folder in the user's directory (similar to how you can do it for the "My Documents" folder in XP).  When changing the location it will ask you if you want to move the existing data to the new location. 

    In Vista I created new folders on the E: partition that mirrored the user directory structure on the C: partition.  I then changed the existing user folders (Documents, Favorites, etc) to be on my E: partition.  Then I decided to import my IE favorites into IE 7.  The favorites import said it was successful and appeared to have worked.  However, I noticed when I tried to add a new favorite that I would get an 'operation failed' message.

    I mucked around a bit and noticed that the issue would go away if I moved the Favorites user-directory back to the C: drive (where it was originally).  However, this is not what i want because I want to keep my user data on the E: partition to keep my backups simple.

    So it seems that those who've posted to this thread that kept using the original "C:\Users\<username>\Favorites" wouldn't have this issue.  It seems that the issue appears when you use a different favorites location.

    Does anybody know if there is anything special that needs to be done to a NTFS partition that's been kept over from XP?  And, keep in mind that I did not do an in place upgrade. 

    It seems like all of the old directories and files would still have the old permissions (ACLs?) for the old users.  Although, I did keep the same user names but I doubt whatever internal account IDs would match.

    Thanks,

    Shawn

    Tuesday, February 13, 2007 3:12 AM
  • I finally found a real explanation with a solution for this problem on the "microsoft.public.windows.vista.general" Microsoft Discussion group.

    Here's the thread:

    http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?query=Favorites&dg=microsoft.public.windows.vista.general&cat=en_us_fdf138d6-427a-48d6-84dc-a91a6c9fbb45&lang=en&cr=us&pt=&catlist=&dglist=&ptlist=&exp=&sloc=en-us

    Problem explained:   there's a new permission concept in Vista called "integrity".  By default all files on your computer have "medium" or higher integrity.  Applications that do not meet or exceed an integrity class cannot modify the files.  When Internet Explorer is running in "protected mode" (must be the default on Vista) it runs with "low" integrity to prevent rogue apps from modifying your files without your permission.

    Solution: 

    • Open an admin command prompt (right-click Command Prompt and click Run As
      Administrator)
    • Browse to the folder that contains your favorites folder
    • Type: icacls favorites /setintegritylevel (OI)(CI)low

    Thanks to "Jimmy Brush, Microsoft MVP" for the info!!!

    Cheers,

    Shawn

    Tuesday, February 13, 2007 10:20 PM
  • I ran into the same issue, and this worked for me perfectly with minimum work.

    1. Since you can still read your old stuff, drop them into your Favorite folder on Vista. Now you should be able to see thow in IE7.

    2. Use File->Import and Export to export your favorites into bookmark.htm

    3. Go to your Favorite folder, delete all.

    4. Go back to IE, Import from the file you just exported.

    5. Everything works now :)

    Saturday, February 17, 2007 2:44 AM
  • I was having the same problem, this worked great.

    Thanks!
    Tuesday, July 3, 2007 3:52 AM
  • I've tried everything here - including the registry tweak. When I tried the 'export-import' trick, it exported, but I get an 'Error Converting Bookmarks' message when I try to import - and I have no favorites.

     

    Even now, when the 'Favorites' folder is empty, I still get an 'unspecified error' when I try to save a link. I thought maybe a security issue - but I am Administrator, and I have 'full control' over the folder (and all the ones above it).

     

    I've had Vista for 4 days now, things like this don't inspire confidence.

     

    A very frustrating error.

     

    A

    Thursday, October 11, 2007 6:32 AM
  • Joseph anothers

    I am a new user and bought a laptop with vista. My old dell was upgraded to XP. Now I cannot sent my internet favorites to my new laptop. I have tried the import and export wizard. does not work. vista does not recognise my old website shortcuts and tags.

    Any suggestions?

    Saturday, December 1, 2007 3:11 PM
  •  

    Saturday, December 1, 2007 3:25 PM
  • Ananix,

    Since you were able to export, I assume you get a bookmark.htm file at the end, or some sort of HTML file. Try open up that file in a browser, if the export was successful in the first place, you should be able to see a hierarchical structure of text showing all your favorites in a web-page fashion.

    Look for things that look corrupted in there. (like random text in foreign encoding that might cause problem). If things look OK, and you can click on all the hyperlinks in that page to go to your favorite website, then the problem is more likely to be in the Import functionality. But let's narrow down one at a time. Let's see if export is even working now.

    Btw, in my previous workaround instruction, the purpose of the step of deleting favorite files is to avoid duplicates once the import is done. When you export, you should make sure all your favorite files are there, otherwise you'll get an empty bookmark.htm, which will leave nothing to import when you try to import it.
    Saturday, December 1, 2007 7:40 PM
  • Wazimu, if you can tell me the steps you've tried, I might be able to come up with some ideas.
    Saturday, December 1, 2007 7:43 PM
  • Worked great, thanks

    Monday, December 31, 2007 6:25 PM
  • My problem exactly! Thanks for explaining it so well. I also have Groove 2007, Office 2007 Pro and Vista Ultimate.

     

    Saturday, January 12, 2008 5:30 PM
  • Yes, that worked. I have Groove 2007, Office 2007 Pro and Vista Ultimate. I think the problem started after I imported, but I made several changes at once. Turning off add-ins was no help. But when I went in and took "co-owner" permission for sharing...voila! I started saving bookmarks again. Thanks.

     

    Saturday, January 12, 2008 5:55 PM
  • I've had a similar problem - I couldn't add any favourites in IE7. I've tried to lower the integritylevel of the Favorites folder and it works.

    Just open the command prompt as administrator and execute the following command:

    icacls X:\path\to\Favorites /setintegritylevel (OI)(CI)low

     

    After you lowered the permission settings of this folder, IE is able to add pages to your favorites.

     

    There is a similar problem printing webpages in IE7 results in an error. After fixing the integritylevel of the IE temp folder it works, too.

     

    Kind Regards,

    David

    Thursday, January 17, 2008 11:26 AM
  • Used the fix by Joseph Lai... (Export - Delete Old Ones - Import the Exported File)

     

    YES! This worked perfectly! What had been happening was that in Vista Home Premium I could only add a bookmark to the main "Favorites" folder and then have to drag/drop into Favorites sub-folders.

     

    The Export was a piece of cake. Deleting the old ones not so much as I couldn't figure out how to multi-select and had to delete each one individually.

     

    But no worries! It was scary to see Favorites EMPTY (gulp!) but the Import was as easy as Export and there they are again!

     

    I see a difference as soon as I "Add to Favorites..." I now get a detailed choice of destinations and can save to any of those Sub-Folders.

     

    Excellent fix and well-worth registering to post and say THANKS!

     

    Hey - check my Signature - it's the equivalent to the Tech-Advice here and can REALLY fix your life! I am living it!

     

    Saturday, January 19, 2008 7:02 AM
  •  Ananix wrote:

    I've tried everything here - including the registry tweak. When I tried the 'export-import' trick, it exported, but I get an 'Error Converting Bookmarks' message when I try to import - and I have no favorites.

     

    Even now, when the 'Favorites' folder is empty, I still get an 'unspecified error' when I try to save a link. I thought maybe a security issue - but I am Administrator, and I have 'full control' over the folder (and all the ones above it).

     

    I've had Vista for 4 days now, things like this don't inspire confidence.

     

    A very frustrating error.

     

    A

     

    I have had Vista Home Premium since Christmas. Not one crash. Only issue so far was this MINOR Favorites/Bookmark annoyance. My hardware has all been good - did have to mess with the scanner driver a little - found fix online in less than twenty minutes.

     

    I think the most horror stories w. Vista are due to trying to use all of the old software and hardware. Not that this is necessarily your situation, but with such a new OS we need to adopt the mindset that we need to start fresh - including hardware and software. I'm betting that my story is the same with folks who purchase machines built for and loaded with Vista from Day One. It's the Upgrade-to-Vista or Wipe-XP-and-Put-Vista-on-My-Older-PC people who will have troubles.

     

    As long as my earlier Word files, etc can still be accessed, then no worries.

     

    I DID do some research and knew going in that my choice needed to be start fresh or stick with WinXP if I did not want to go that route. I also researched which of my favorite software titles would/wouldn't run well in Vista.

     

    Hang in there! One good thing is that WinXP will be around for quite a while and I just saw it advertised for like $139 - I can scrounge that much and go back if I decide to.

    Saturday, January 19, 2008 7:23 AM
  •  

    I have the same issue. i cannot remember if I overwrote the Favorites folder using the one from XP or if I copied all the content in the Favorites folder from XP to the Favorites folder in Windows Vista Ultimate, but I do know that I did one of the two things mentioned and that I cannot add favorites or anything to my links bar now...

     

    So the things i have tried to resolve the matter:

     

    A) Deleted every single item in the favorites list (Kind of a pain, as another user mentioned, deleting items one at a time is a real usability problem. It took me 2 hours and I am no slouch when it comes to clicking things fast Smile

     

    B) Went back to my XP machine and exported bookmarks.htm and tried to import it on the Vista Machine.

     

    C) Checked for corruption in this file, none readily visible, but it doesn't seem to be the issue anyways because I am looking at an empty Favorites folder and cannot save this page I am typing into right now as a favorite.

     

    D) "Attempted" to run the suggested command line:

    icacls X:\path\to\Favorites /setintegritylevel (OI)(CI)low

     

    C:\Users\Matt>icacls X:\path\to\Favorites /setintegritylevel (OI)(CI)low
    The system cannot find the path specified.
    Successfully processed 0 files; Failed processing 1 files

     

    OOps! I should read closer:

     

    icacls X:\path\to\Favorites /setintegritylevel (OI)(CI)low

     

    Okay let me try that again:

     

    C:\Users\Matt>icacls E:\My Documents\Favorites /setintegritylevel (OI)(CI)low
    Invalid parameter "Documents\Favorites"

     

    I am not a windows guy, but it seems like it does not like the space between "My" and "Documents"

     

    In Linux I would add quotes to get around this problem. Let me try that:

     

    C:\Users\Matt>icacls "E:\My Documents\Favorites" /setintegritylevel (OI)(CI)low
    E:\My Documents\Favorites: Access is denied.
    Successfully processed 0 files; Failed processing 1 files

    So I have tried everything here except running the suggested commandline. Can someone tell me what is wrong with my syntax or why windows is failing to process this file?

    Tuesday, June 10, 2008 9:35 PM
  •  

    Well, i do not know if its the recommended fix but there was a pretty simple fix for this and that was to go to the selected folder that was giving me permission problems and right-click it > properties > security > Edit Permissions and give "Full Control" to the user who has the issue. Problem solved for me.

     

    I cannot see why this would be a security issue so if anyone knows feel free to chime in.

    Tuesday, June 10, 2008 10:07 PM
  • I have tried the above on my new vista laptop.  However icalcs does not seem to exist:  'icalcs' is not recognized as an internal or external command, operable program or batch file.

     

    Is there something I must do to turn 'icalcs' on?

     

    Thank you so much for your kind help.

     

    KT

     

    Wednesday, September 24, 2008 12:09 PM
  • Try this. simple and worked for me.

    http://www.winhelponline.com/blog/error-not-a-valid-bookmark-file-when-importing-ie8-bookmarks-favorites-to-ie7/


    Tuesday, May 19, 2009 6:30 PM