locked
Disable Cached Mode in Outlook 2016 via GPO RRS feed

  • Question

  • Hi,

    I just upgraded from Exchange 2010 to Exchange 2013 and Outlook 2010 to Outlook 2016. All the users are onsite and for security reasons I want to disable Cached Mode in Outlook 2016. I have MS office 2016 ADMX template in my GPO. These are the GPO settings that I have disabled:

    Cached Exchange Mode (File|Cached Exchange Mode)  - Disabled
    Use Cached Exchange Mode for new and existing Outlook Profile - Disabled.

    GPO is getting applied but Use Exchange Mode on the Outlook setting is not greyed out. Users are still able to make the changes. This is odd. It worked in outlook 2010.

    Am I missing something?

    Thanks

    Tuesday, March 15, 2016 1:08 PM

Answers

  • Hi,

    In theory, when the listed GPO settings are applied, the "Use Cached Exchange Mode" option should be grayed out.

    Please open the Registry Editor and check if the following registry entry is correct:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\outlook\cached mode

    DWORD: Enable

    Value: 0

    Please also run the following command and make sure the GPO settings are correctly applied:

    gpresult /h gpreport.html

    Please let me know the result.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Marked as answer by tamangketa Wednesday, March 16, 2016 3:12 PM
    Wednesday, March 16, 2016 3:02 AM

All replies

  • Hi,

    In theory, when the listed GPO settings are applied, the "Use Cached Exchange Mode" option should be grayed out.

    Please open the Registry Editor and check if the following registry entry is correct:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\outlook\cached mode

    DWORD: Enable

    Value: 0

    Please also run the following command and make sure the GPO settings are correctly applied:

    gpresult /h gpreport.html

    Please let me know the result.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Marked as answer by tamangketa Wednesday, March 16, 2016 3:12 PM
    Wednesday, March 16, 2016 3:02 AM
  • I am having the same issue. Did you get this resolved?
    Wednesday, March 15, 2017 10:18 PM
  • To enforce it, I apply a reg key with GPO.
    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\outlook\
    Name: NoOST
    Type: REG_DWORD
    Data: 2

    0 - An offline store is set up by default and used for calendar caching. Also, the user is allowed to enable offline access and use the offline store. This is the same as the absence of the OST key and NoOST value.
    1 - An offline store is set up by default and used for calendar caching. However, the user is not allowed to enable offline access and use the offline store. The options in the Microsoft Exchange Server properties are not available.
    2 - An offline store is not set up by default and the user is not allowed to enable offline access and use the offline store. The options in the Microsoft Exchange Server properties are not available.
    3 - An offline store is not set up by default and the user is allowed to enable offline access and use the offline store.
    • Proposed as answer by Coert K Friday, May 26, 2017 2:01 PM
    Thursday, April 6, 2017 8:28 AM
  • These two articles may clarify options:

    SOLVED: How To Block Outlook From Using Cached Mode on Boardroom PC’s
    https://www.urtech.ca/2019/08/solved-how-to-block-outlook-from-using-cached-mode-on-boardroom-pcs/ 

    Solved: How To Push a User GPO To Only Some Computers
    https://www.urtech.ca/2019/08/solved-how-to-push-a-user-gpo-to-only-some-computers/ 

    I hope the help others.


    Ian Matthews www.urtech.ca www.commodore.ca

    Tuesday, August 27, 2019 1:55 AM