locked
macros not working in word 10 RRS feed

  • Question

  • HI there - i'm not a IT pro but fairly savvy small biz owner -- my sharp son is in IT but didn't know - i have a bunch of short macros made for simple tasks with icons on the toolbar, after I set them up and use them once, the next boot up gives me the same error message - I'

    i've done all the macro settings properly as far as I can see - so i made this short screen capture

    Hi there – can u listen and help here? thx!

    http://screencast.com/t/uTyjYOw85X2

     macro security settings

    http://screencast.com/t/K24PCg6q

    This message can appear if:

    ·The macro was deleted from the template.

    ·The template was not loaded or referenced in the Templates and Add-ins command.

    ·The macro was turned off by the macro security settings of your system.

    If the macro security settings are not allowing the macro to run, you should confirm the origin of the macro to be sure that it can be trusted (contact the developer or the source for the macro). You can then temporarily enable all macros by using the following procedure.

    1. Click the File tab, click Options, click Trust Center, and then click Trust Center settings.
    2. Click Macro Settings.
    3. Under Macro Settings, click Enable all macros.

    NOTE: Be sure to change this option back to its original setting after you have run the macro.

    If the macro is not accessible because the template is not loaded, click the File tab, click Options, and then click Add-Ins. At the bottom of the Add-Ins pane, select Templates from the Manage drop down list, and then click Go. In the Templates and Add-ins dialog box, click either Attach or Add. If the macro is not in the template, you may need to copy the macro from one template to another. Click the Organizer button at the bottom of the Templates and Add-ins dialog box to start the Organizer utility.

    Saturday, September 27, 2014 6:10 PM

Answers

  • Since you have allowed all macros, the problem appears to be that the macros are not available.

    I noticed in your screencast that the screentip for one of the macros read Normal.NewMacros.Indent. That indicates that the macro should be found in your default template Normal.dotm. For another, the screentip was Project.NewMacros.Bold or something like that. That makes me suspect the macro is NOT in Normal.dotm

    From Word, press Alt+F11 to activate the Visual Basic Editor.

    You'll see the Project Explorer on the left hand side. In the screenshot above, you see that my Normal template has one module, named basCode. The macros in this module are globally available in Word.

    Check whether you can find macros in your Normal template, under Modules. Double-click a module to see its contents.


    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    • Marked as answer by Greta Ge Wednesday, October 8, 2014 5:39 AM
    Saturday, September 27, 2014 6:40 PM