FIM 2010 Self Service error (SSPR)


  • We are facing a inconsistent behavior in SSPR. Below is the detail of the issue

    Have installed the Add-on for SSPR and Registration for Challenge Q&A works successfully.

    But, when I try to reset password for the first time it works fine but after that most of the times it does not get through. Many a times when it works it gives an option for debugging due to “Just in Time” compiler error on Sync Server. When this error occurs the “Synchronization service” stops and I have to manually restart the same. And very rarely the password reset works without any error. And to my notice I have followed the same procedure for all the test cases with different/same end-user ID(s). This particular debug error pops up on sync server. Below are the screenshots for same. Also, attached event log error with a “PWReset Activti’s Miis password set call failed with call-failure:0x800706BE


    Also, many a times it does not work even when I am trying to reset the password for first time. I get the above mentioned error in screenshot.

    Fyi, I would have answered the Challenge Q&A successfully. Post which when I try to reset password I get the error

    I tried below mentioned Corrective steps but no luck.

    1. Made sure the steps for SSPR installation and configuration are fine.
    2. Uninstalled and Reinstalled Add-ins.
    3. Took a restart of end user system along with Sync/ Portal/ Service servers.
    4. Tried Password reset on existing users once again but the error still exists.
    5. Created a new user and tried the exercise but no use.
    6. Tried to look in some forums and came to know it might be a permission issue for AD MA user. But I have cross checked and required permissions are in place.
    7. In few of the forums I found that people have faced same errors but no proper resolution. There are few suggestions which I have tried but with no result.

    In any case, 8 out of 10 attempts on password reset through Gina Passwords are being Reset successfully though an error has occurred and very rarely the passwords are not being reset successfully and obviously with the error as in above screenshots.

    Any Idea/Suggestion? Appreciate your quick response.


    Chandan R

    Tuesday, April 10, 2012 8:21 AM

All replies