none
Upgrade 9.0 to 9.1 - Code Execution Test: Fail RRS feed

  • Question

  • I used 9.0.1 for awhile on a windows server 2012 R2, and it worked great. 

    I tried to upgrade following the steps online, and everything works until I configure for operationalize. 

    The Web node and compute node pass but the code execution test fails with:

    HTTP Status Code Exception
     Status Code ServiceUnavailable at Url http://localhost:12800/sessions{"Link":"https://go.microsoft.com/fwlink/?linkid=830136","Message":"Exception of type 'Microsoft.RServer.Domain.Exceptions.ServiceBusyException' was thrown.","ExceptionType":"ServiceBusyException"}

    Has anyone seen this error before?

    Thursday, May 18, 2017 8:35 PM

Answers

  • https://social.msdn.microsoft.com/Forums/en-US/09f1e32c-62e9-4fa9-b34d-c2ca18b3051f/backendbusyexception?forum=MicrosoftR&prof=required

    rllmuk_ shows the answer as a Corporate Proxy issue.

    Add

    utils::setInternet2(TRUE)

    to <install folder>\R_SERVER\etc\Rprofile.site on a new line.


    • Marked as answer by Dekadr2017 Thursday, August 31, 2017 9:03 PM
    Thursday, August 31, 2017 9:03 PM

All replies

  • I luckily could revert back to 9.0.1 (installer limbo...) and noticed a few differences if it helps anyone in the future:

    On 9.1 Configuration with the Utility program,

    1.) Compute node would throw an error because the Rserve9.0.0.0 "log on as a service" permissions were not set.

    9.1.0: Setting the permissions, would run the compute node successfully, but the PID was not setup for the service (exception thrown). So, this required going back to main menu, and hit 3: start and stop services > D: Start compute node.  

    9.0.1: Setting the permissions, would run the compute node successfully, but the PID for the service was already setup. 

     

    2.)  Rserve.exe and BxlServer.exe repetitively being setup 

    9.1.0: On the list of services, almost 6 were present at one time. 6: Run diagnostic tests > A: Test configuration ends with the error above. 

    9.0.1: Only 2 for each and 6: Run diagnostic tests > A: Test configuration  works fine, able to remote login. 

    Friday, May 19, 2017 6:52 PM
  • https://social.msdn.microsoft.com/Forums/en-US/09f1e32c-62e9-4fa9-b34d-c2ca18b3051f/backendbusyexception?forum=MicrosoftR&prof=required

    rllmuk_ shows the answer as a Corporate Proxy issue.

    Add

    utils::setInternet2(TRUE)

    to <install folder>\R_SERVER\etc\Rprofile.site on a new line.


    • Marked as answer by Dekadr2017 Thursday, August 31, 2017 9:03 PM
    Thursday, August 31, 2017 9:03 PM