locked
Sequencing and Vista UAC RRS feed

  • Question

  • Hi All

    We are sequencing using App-V 4.5CU1 on Windows Vista SP2 with UAC enabled and we're following Microsoft's best practise guidelines when sequencing. We're finding that several sequenced applications only run when we launch them using elevated privelages (ie right click on the shortcut and select 'run as administrator')

    For example, we have sequenced several IE 7 plugins (flash, shockwave, JRE) and if we launch IE 7 as a standard user, the App-V client launches Internet Explorer and it is very slow to load and when IE finally loads, the sequenced plugins do not work. When we launch the same shortcut with administrator privilages, the App-V client instantly launches Internet Explorer and we can use the plug-ins with no problems.

    This is also the case with other applications that have been sequenced - if they are launched as a domain user performance is impacted or the application fails to load, however if the same virtual applications are launched with the adminitrator token then they work without any problems.

    If we turn off UAC, then we can launch the virtual applications as a domain user with no problems at all and they work flawlessly -  unfortunately this is not an option as we require UAC enabled.

    Any ideas/suggestions?

    Thanks
    Tuesday, September 8, 2009 2:58 AM

Answers

  • Hello,

    Have you tried sequencing with UAC switched off?

    /Znack
    • Proposed as answer by znack Friday, September 11, 2009 5:14 PM
    • Marked as answer by Aaron.ParkerModerator Saturday, November 17, 2012 1:56 PM
    Wednesday, September 9, 2009 5:04 AM

All replies

  • Hello,

    Have you tried sequencing with UAC switched off?

    /Znack
    • Proposed as answer by znack Friday, September 11, 2009 5:14 PM
    • Marked as answer by Aaron.ParkerModerator Saturday, November 17, 2012 1:56 PM
    Wednesday, September 9, 2009 5:04 AM
  • I'd second the UAC being off during sequencing.

    It's stated as best practise somewhere to keep UAC on at the Sequencer, but I cannot fathom any reason why you actually need it to be on. Especially since UACs one part is registry/file redirection features which you definitely do not want to use while monitoring changes..

    /Kalle
    Thursday, September 10, 2009 3:21 PM
    Moderator
  • Hi guys

    Thanks for the replies. Unfortunately I have already tried sequencing with UAC disabled and it does not resolve the issue. I am speaking with a lead App-V developer engineer at Microsoft about this issue so if I have any success I'll post the resolution here.

    Thanks again.
    Monday, September 14, 2009 12:29 AM
  • Did you ever receive an answer from Microsoft?  We are running into the same thing while sequencing for Windows 7. 
    Tuesday, December 8, 2009 4:12 PM
  • I also have this issue in Windows 7. I'd be really interested in what that App-V developer said. Right now, this alone has made us turn off UAC.
    Friday, January 15, 2010 3:37 PM