Acer Laptop stuck at "Setup is Starting Services," can't move on AT ALL!


  • Hi! I've been having a serious issue with my Acer Aspire (Windows 7) laptop since around 3am last night. Before I go on, please note that I have been searching for solutions before posting this question, and none of what I've found matches my situation and/or solves the issue.



    -"Windows could not complete the installation. To install windows on this computer, restart the installation" error window keeps showing up, forcing me to click OK, and restart (causing same error over and over)

    -After the above error, and another attempt to restore, this error shows "The computer restarted unexpectedly or encountered an unexpected error. Windows Installation cannot proceed. To install windows, click OK to restart the computer and then the installation."

    -can't access login screen after continues restarts

    -AtBroker.exe and Explorer.exe not running (and probably other important .exe as well?)

    -None of the Safe Modes are accessible

    What I've done so far:

    -begin restore process (not factory default! the process included backing up my files)

    -continuous restart and encounter "Windows could not complete the installation. To install windows on this computer, restart the installation."

    -F8 to start the "Last known good configuration," just led me back to the current issue.

    -F8 to boot in Directory Services Restore Mode, went back to trying to install in Safe Mode, forced me to restart.

    -F8 to disable automatic restart (failed and made me restart anyway)

    -F8 to "Disable Driver Signature Enforcement"... also failed

    NOTHING I've done has made any advancement past the "Setup is starting services."


    Last night, I was installing a new theme on my laptop (from a 3rd party on deviantart, but I was carefully following instructions to not mess anything up, using theme manager. however it's probably the reason for the issue) and everything was going well. i had to restart occasionally to make sure the themes worked but on my final restart (after I decided I preferred a previous theme), everything went wrong! After logging in, the screen turned gray (it'd probably be black for others, but mine was gray maybe due to the theme) and the cursor was there just flickering. And this continued for about 10 minutes before I tried opening task manager but that failed (said the .exe wouldn't start properly) so I shut it down (through ctrl+alt+del) and restarted. Still same issue, but this time it said that AtBroker.exe and then explorer.exe were unable to run properly, preventing me from even seeing my desktop.

    So today when I got home, I ended up going through the Acer eRecovery Management and doing a system restore (but it would keep my files, just restore the settings to how they were when my parents bought the laptop (summer-ish 2011)). It took a while and it looked promising. Eventually, it took me to the screen with the Windows logo, then to a screen that said "setup is starting services"). And it gave me an error that it couldn't continue installation so it had to restart, so I clicked OK. It happened again. Clicked OK and repeated that 2 more times until I got fed up. I just want to skip around that installation and try to access my desktop or at least Command Prompt but it won't let me get any further without making me restart (by clicking OK). I also do not recall any disk when my dad set my laptop up but this was 2 years ago. I can't find one either, so I assumed Windows 7 came with it?

    I really don't know what to do! Nor am I really tech savvy when it comes to fixing this kind of computer problem, so if anyone has any solutions, I wouldn't really know a lot of terms that would be important to know when it comes to fixing this issue. Hopefully, someone can explain what's happening and how I can fix it fairly simply.



    • Edited by OliviaDubb Monday, October 14, 2013 7:44 PM
    Monday, October 14, 2013 7:01 PM


All replies