none
Windows 10 Firewall Blocking SMB Scanning. RRS feed

  • Question

  • I am trying to scan documents from a Ricoh and Canon Copier to a shared folder on my W10 system.  I have enabled all SMB rules in Win Firewall and am getting nothing.  As soon as I turn the firewall completely off the scans go through with no issues.  Anyone have any clues where to go from here?
    Friday, August 7, 2015 8:40 PM

Answers

  • Hi,

    Since the problem will not happened once the firewall is turned off, we need to look into the rules configured on Windows Firewall.

    Firewall rules are corresponding to different Network Profile, such as domain, private. First make sure your network profile type on Windows 10, and then enable rules corresponding to the network profile.

    Make sure that below rules are enabled on Inbound Rules:
    File and Printer Sharing (NB-Name-In), UDP 137.
    File and Printer Sharing (NB-Session-In), TCP 139.
    File and Printer Sharing (SMB-In), TCP 445.
    File and Printer sharing (NB- Datagram-In), UDP 138.

    If the problem persists, you may try below configuration:
    Control panel – Windows Firewall – Allow an app or feature through Windows Firewall – Change Settings, check the option “File and Printer sharing” – save the change.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 11, 2015 8:24 AM

All replies

  • Hi,

    Since the problem will not happened once the firewall is turned off, we need to look into the rules configured on Windows Firewall.

    Firewall rules are corresponding to different Network Profile, such as domain, private. First make sure your network profile type on Windows 10, and then enable rules corresponding to the network profile.

    Make sure that below rules are enabled on Inbound Rules:
    File and Printer Sharing (NB-Name-In), UDP 137.
    File and Printer Sharing (NB-Session-In), TCP 139.
    File and Printer Sharing (SMB-In), TCP 445.
    File and Printer sharing (NB- Datagram-In), UDP 138.

    If the problem persists, you may try below configuration:
    Control panel – Windows Firewall – Allow an app or feature through Windows Firewall – Change Settings, check the option “File and Printer sharing” – save the change.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 11, 2015 8:24 AM
  • Thank YOU!!!!
    Sunday, February 3, 2019 7:41 PM