locked
Joining external meeting From Lync Web App is slow on SilverLight RRS feed

  • Question

  • Hi!

     I have a problem with Lync 2010 "Join the meeting using your web browser" taking long to connect for our external users.  Each time an external user tries to connect using their web browser, the Silverlight client will launch and take about 3 minutes on initialize before the user can sign in as a guest.  Wondering what could cause this delay since “Join the meeting” using Silverlight from inside the network or even on the TMG server is instant with no delay.

    I'm currently running Lync Standard Edition with Lync Edge and TMG 2010 as a reverse proxy.

    Any tips would be helpful

    Thanks

    Monday, August 20, 2012 12:42 AM

Answers

  • Hi,

    Did the issue occur for all external users?

    The remote Lync Web App client initially requires only Transmission Control Protocol (TCP) Port 443 HTTPS connectivity to the external edge of the Forefront Threat Management Gateway TMG reverse proxy solution to provision the client's remote user sign-in process.

    I suggest trying to turn off firewalls on client computer to test the issue.

    If the issue persists, please try to enable the logging tool on reverse proxy and reproduce the problem then get the detailed reports.

    Logging tool:

    http://technet.microsoft.com/en-us/library/gg558599.aspx

    http://www.ultimate-communications.com/2010/11/how-to-troubleshoot-lync-using-lync-server-logging-tool-snooper-v4/


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Tuesday, August 21, 2012 2:58 AM
    • Marked as answer by Kent-Huang Wednesday, September 5, 2012 7:26 AM
    Tuesday, August 21, 2012 2:57 AM
  • Hi,

    The DNS records you describe are correct. sipinternal._tcp. <domainname> is not needed for internal DNS. Please try to check the port redirection on Reverse proxy. By default, the Lync Internet Information Services (IIS) server uses port 443 for internal clients and port 4443 for external clients.

    Please try to add ?sl= to the end of the meeting URL to check if we can john the meeting quickly. This change bypasses the Lync 2010 client check. The URL will look something like this:

    https://meet.<domainName>.com/<userName>/7GYFDT98?sl=

    In addition, please install the latest version of Silverlight.


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Thursday, August 30, 2012 6:50 AM
    • Proposed as answer by Kent-Huang Friday, August 31, 2012 8:52 AM
    • Marked as answer by Kent-Huang Wednesday, September 5, 2012 7:26 AM
    Thursday, August 30, 2012 6:50 AM

All replies

  • Hi,

    Did the issue occur for all external users?

    The remote Lync Web App client initially requires only Transmission Control Protocol (TCP) Port 443 HTTPS connectivity to the external edge of the Forefront Threat Management Gateway TMG reverse proxy solution to provision the client's remote user sign-in process.

    I suggest trying to turn off firewalls on client computer to test the issue.

    If the issue persists, please try to enable the logging tool on reverse proxy and reproduce the problem then get the detailed reports.

    Logging tool:

    http://technet.microsoft.com/en-us/library/gg558599.aspx

    http://www.ultimate-communications.com/2010/11/how-to-troubleshoot-lync-using-lync-server-logging-tool-snooper-v4/


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Tuesday, August 21, 2012 2:58 AM
    • Marked as answer by Kent-Huang Wednesday, September 5, 2012 7:26 AM
    Tuesday, August 21, 2012 2:57 AM
  • Hi Kent, thanks for the quick response.  The issue appears to be for all external users even when the Window Firewall is disabled.  Should I be installing the Lync logging tool on our TMG Reverse Proxy Server? 

    If so, I used the Lync 2010 DVD to install the Lync topology builder on the TMG Server follow by installing OCSReskit.msi from: http://www.microsoft.com/en-us/download/details.aspx?id=21165

    When launching the logging tool on the TMG server, I noticed some of the logging options components are missing.  Example:  UserServices and SipStack are missing.   Capturing S4 traffic doesn’t record any data on the Log Files. 

    Thoughts?

    Should I be logging from the Edge server or Lync Front Server as well?




    • Edited by lyncnoob Wednesday, August 22, 2012 6:29 AM
    Tuesday, August 21, 2012 9:02 PM
  • I don't know if this would shed any lights on the matter but when I run a packet capture on my firewall, I noticed when the external user connect via Silverlight Lync Web app the External source pass traffic through port 5061 and 443 over the Reverse Proxy.  Is this normal?  My external svr records points _sipfederationtls._tcp.domainname.com to port 5061 and _sip._tls.domainname.com to port 443.  Could this slowness be caused by incorrect DNS records?  My TMG is not joined to the Domain and resolve records through it's host file.

    Is  sipinternal._tcp. <domainname> needed for internal DNS?  I only have _sipinternaltls._tcp.<domainname> created at this time

    Thoughts?

     

     



    • Edited by lyncnoob Wednesday, August 29, 2012 3:02 AM
    Wednesday, August 29, 2012 2:51 AM
  • Hi,

    The DNS records you describe are correct. sipinternal._tcp. <domainname> is not needed for internal DNS. Please try to check the port redirection on Reverse proxy. By default, the Lync Internet Information Services (IIS) server uses port 443 for internal clients and port 4443 for external clients.

    Please try to add ?sl= to the end of the meeting URL to check if we can john the meeting quickly. This change bypasses the Lync 2010 client check. The URL will look something like this:

    https://meet.<domainName>.com/<userName>/7GYFDT98?sl=

    In addition, please install the latest version of Silverlight.


    Regards,

    Kent Huang

    TechNet Community Support ************************************************************************************************************************ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Kent-Huang Thursday, August 30, 2012 6:50 AM
    • Proposed as answer by Kent-Huang Friday, August 31, 2012 8:52 AM
    • Marked as answer by Kent-Huang Wednesday, September 5, 2012 7:26 AM
    Thursday, August 30, 2012 6:50 AM
  • Hello Kent, after running Wireshark I discovered Silverlight Web App was first trying to resolve our External TMG address meet.domainname.com then after it tries to resolve the Lync Front End Server DNS name.  When it times, since we have no Public A record for our Front End Server, Lync web connect using meet.domainanme.com.  

    When I created a public A record to resolve Lync Front End Server to our TMG address the slowness goes away.  Do you know of any trick to edit this hidden URL annoyance?

    When I look at my Lync topology the External Web FQDN appears correct

    Tuesday, October 2, 2012 3:58 AM