none
PS2010: project site creation fails with custom template (even if it is equal original template) but works with original template RRS feed

  • Question

  • I saw in this forum some very similar questions about this issue, but the solutions did not fit to my case.

    • 1. My PS 2010 is in English with Brazilian Portuguese Language Pack. It already worked with custom site template some time ago, but it stopped to work more or less when we installed the Service Pack 2. We did extensive tests but we could not link the problem to the pack.
    • The issue is that when we use the original PS template in English or Portuguese, the Project site is created without any problem. If we create na empty Project and alternatively a new site using the Project Server template without any customization and save as a template and published a Project. it failed in both cases. It creates the site, but fails to syncronize the users so no one can access it. An excerpt of the error message from the queue shows the following:

    "The content type name _$Resources:ReportServerResources,DataSourceContentTypeName;_ cannot contain: \ / : * ? " # % < > { } | ~ & , two consecutive periods (..), or special characters such as a tab. at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft."

    • As I am using the original site as is, it could not be any special character inside the original site. I tried in both languages.
    • I read in other answers that a Reporting Services installation could be the cause, but we do not installed the Reporting Service integration or stand alone.
    • We disabled the automatic creation of the site and tried to create manually in the Server Cofiguration option and we got the same failure.
    • I looked at ULS log and there is not anything different fron the above error message.
    • I also created another instance in the same from the scratch without any customization in PWA and made the same tests and I got the same error.

    Any ideas on how to find a solution?

    Thank you.


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner

    Wednesday, October 2, 2013 1:44 AM

All replies

  • While I can't solve your problem, I definitely ran into this exact issue in a 2013 beta environment.  We never figured out the fix, as it seemed to just begin working one day.

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Wednesday, October 2, 2013 2:41 AM
    Moderator
  • Thank you Andrew.

    I hope other readers can give me more hints.


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner

    Wednesday, October 2, 2013 3:07 AM