locked
Sharepoint 2010 Search RRS feed

  • Question

  • I created content source after that i full crawled it, but it throws top level error Access Denied.

    Search is not working, i didn't understand search is working on the Test server but not on production server.

    Please suggest the possible cause of the error access denied to content database, although i am using Administrative right containing user.

    Friday, June 24, 2011 7:06 PM

Answers

  • Hi,

    Try to disable loopbackcheck and run the crawl again.

    Method 1 (recommended): Create the Local Security Authority host names that can be referenced in an NTLM authentication request
    To do this, follow these steps for all the nodes on the client computer:
    Click Start, click Run, type regedit, and then click OK.
    Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    Right-click MSV1_0, point to New, and then click Multi-String Value.
    In the Name column, type BackConnectionHostNames, and then press ENTER.
    Right-click BackConnectionHostNames, and then click Modify.
    In the Value data box, type the CNAME or the DNS alias, that is used for the local shares on the computer, and then click OK.

    Note Type each host name on a separate line.

    Note If the BackConnectionHostNames registry entry exists as a REG_DWORD type, you have to delete the BackConnectionHostNames registry entry.
    Exit Registry Editor, and then restart the computer.

    Method 2: Disable the authentication loopback check
    Re-enable the behavior that exists in Windows Server 2003 by setting the DisableLoopbackCheck registry entry in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa registry subkey to 1. To set the DisableLoopbackCheck registry entry to 1, follow these steps on the client computer:
    Click Start, click Run, type regedit, and then click OK.
    Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Right-click Lsa, point to New, and then click DWORD Value.
    Type DisableLoopbackCheck, and then press ENTER.
    Right-click DisableLoopbackCheck, and then click Modify.
    In the Value data box, type 1, and then click OK.
    Exit Registry Editor.
    Restart the computer.


    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    • Marked as answer by Yogesh. S Tuesday, June 28, 2011 4:08 PM
    Friday, June 24, 2011 7:13 PM

All replies

  • Hi,

    Try to disable loopbackcheck and run the crawl again.

    Method 1 (recommended): Create the Local Security Authority host names that can be referenced in an NTLM authentication request
    To do this, follow these steps for all the nodes on the client computer:
    Click Start, click Run, type regedit, and then click OK.
    Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    Right-click MSV1_0, point to New, and then click Multi-String Value.
    In the Name column, type BackConnectionHostNames, and then press ENTER.
    Right-click BackConnectionHostNames, and then click Modify.
    In the Value data box, type the CNAME or the DNS alias, that is used for the local shares on the computer, and then click OK.

    Note Type each host name on a separate line.

    Note If the BackConnectionHostNames registry entry exists as a REG_DWORD type, you have to delete the BackConnectionHostNames registry entry.
    Exit Registry Editor, and then restart the computer.

    Method 2: Disable the authentication loopback check
    Re-enable the behavior that exists in Windows Server 2003 by setting the DisableLoopbackCheck registry entry in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa registry subkey to 1. To set the DisableLoopbackCheck registry entry to 1, follow these steps on the client computer:
    Click Start, click Run, type regedit, and then click OK.
    Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Right-click Lsa, point to New, and then click DWORD Value.
    Type DisableLoopbackCheck, and then press ENTER.
    Right-click DisableLoopbackCheck, and then click Modify.
    In the Value data box, type 1, and then click OK.
    Exit Registry Editor.
    Restart the computer.


    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    • Marked as answer by Yogesh. S Tuesday, June 28, 2011 4:08 PM
    Friday, June 24, 2011 7:13 PM
  • Hi,

    Any progress on this issue?


    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    Saturday, June 25, 2011 11:08 PM
  • Thanks ! I'll try this today directly on the production server.
    Monday, June 27, 2011 4:33 AM
  • Remember you need to restart your server and please test it first in test environment, even though the change is not so major.
    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    Monday, June 27, 2011 6:54 AM