none
MDT 2013 update 2 - sysprep.inf not found in bdd.log after running sysprep and capture TS RRS feed

  • Question

  • Hi everyone,

    We've been using MDT for several years at my company with good success.  I decided to start testing update 2 and followed Johan's upgrade instructions.  I uninstalled ADK8.1, rebooted, installed the latest ADK10, rebooted, then installed update 2 in MDT.  Everything was going fine until I tried to run the sysprep and capture TS on a cleanly provisioned win10 VM.  It finished with no errors in about 30 secs but does nothing.  The BDD.LOG says sysprep.inf not found.  Wasn't sure what to make of that so I checked out the sysprep logs.  The sysprep error log had just one line: "sysprp winmain: the sysprep dialog box returned false".  I can confirm that sysprep does work because I ran it manually and it runs/finishes fine.  I can also confirm that I'm able to access the mdt test box from the win10 vm, so permissions are not the problem.

    Also worth noting that if I run ltisysprep.wsf manually from cmd prompt, sysprep does execute but errors out almost immediately.  If I revert to a clean VM snap and run sysprep manually from the \system32\sysprep folder, it runs/finishes fine.

    Can someone please shed some light on what might be going on here?  I followed Johan's instructions and recreated my task sequences before doing anything.  My customsettings.ini reads as follows:

    DoCapture=YES
    BackupShare=\\testbox\deploymentshare1$
    BackupDir=backup\WIM\MDTREFWIN10
    BackupFile=MDTREFWIN10.wim
    ComputerBackupLocation=NETWORK

    Any help is appreciated.  Thanks!



    Friday, March 11, 2016 11:19 PM

Answers

All replies

  • So...I think I may have figured out what's going on here.  In my cs.ini, the rules for my sysprep/capture are listed under a specific TaskSequenceID...before updating MDT to update 2 I was able to run settings for specific TaskSequenceIDs by tweaking DeployWiz_Validation.vbs.  This was a confirmed bug and it wasn't clear if this was ever planned to be fixed.

    Well here we are again and it seems that this is still a problem.  I guess my first question is, can anyone confirm that this bug is still not fixed in MDT 2013 Update 2?  Second, the DeployWiz_Validation.vbs script is no longer being used after update 2.  I could try the workaround as described here:

    http://blog.mikewalker.me/2013/04/mdt-2012-use-different-settings-per.html

    But I wanted to check with the folks on this board before diving down that rabbit hole.  Lend me your thoughts!  Thanks guys.



    Saturday, March 12, 2016 2:46 AM
  • I ended up going with this solution:

    http://www.the-d-spot.org/wordpress/2012/07/20/how-to-use-different-settings-per-task-sequence-with-mdt-2012/

    That solution works fine so long as you aren't planning on specifying a custom task sequence ini file.  If you want to do that, you'll need to follow Mike's instructions here:

    http://blog.mikewalker.me/2013/04/mdt-2012-use-different-settings-per.html

    I would just like to reiterate that it's ridiculous that this bug still hasn't been fixed.  The longer this problem prevails, the more misleading blog posts pop up and create even more confusion.  I've seen some people suggest swapping out DeployWiz_SelectTS.vbs with one from an MDT2012 build...that's an entirely awful solution as there are significant changes to that file from MDT 2012 to MDT 2013 update 2.  You will need to manually edit DeployWiz_SelectTS.vbs.


    • Marked as answer by resident1155 Saturday, March 12, 2016 4:05 PM
    • Edited by resident1155 Saturday, March 12, 2016 4:07 PM
    Saturday, March 12, 2016 4:05 PM
  • You can file this on connect or give feedback there.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Sunday, March 13, 2016 1:23 AM
    Moderator