none
Exchange 2010 message limits

    Question

  • I have an issue with message size limits in Exchange 2010 as follows:

    When I send a message with an attachment size greater than 10MB I get the following bounce message:

    "This Message was undeliverable due to the following reason. Your message is larger than the destination computer is willing to accept, so it was returned. Size of this message 22385880 bytes. Server maximum size 10485760 bytes."

    I have set the limits on the server using exchange shell as follows:

    1. Organizational limits - I have modified the organizational message size limits using the Set-TransportConfig cmdlet from the Exchange shell as follows: Set-TransportConfig -MaxReceiveSize 40MB -MaxSendSize 40MB

    2. Receive Connector limit - Set-ReceiveConnector “CONNECTOR NAME” -MaxMessageSize 40Mb

    3. Recipient limit - Set-Mailbox “Joe Adams” -MaxSendSize 40Mb -MaxReceiveSize 40Mb

    Is there another place I am forgetting about where the server is limited to the maximum size of 10485760 bytes? 

    Any help would be greatly appreciated?

    Monday, April 4, 2016 8:48 AM

Answers

  • Receive connectors don't have smart hosts.  Do you have an antispam service, server or appliance between the Internet and your Exchange server?  Do you have an Edge Transport server?  You have just Exchange 2010, right, the mailbox isn't on Exchange 2003, is it?

    How many servers do you have and are they in different sites?

    Get-ADSiteLink | FL Name,MaxMessageSize

    Just to double-check:

    Get-TransportConfig | FL MaxSendSize,MaxReceiveSize
    Get-ReceiveConnector | FL Identity,MaxMessageSize
    Get-Mailbox -Identity <Recipient Name> | FL Name,MaxSendSize,MaxReceiveSize


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    • Marked as answer by Coobes Tuesday, April 5, 2016 6:01 AM
    Tuesday, April 5, 2016 5:10 AM
    Moderator
  • I changed the Identity :SERVER\Windows SBS Internet Receive SERVER (receive connector) limit from 10MB to 40MB and it solved the problem.

    I had clearly overlooked this identity when setting the size limit on my receive connectors.

    Thanks Ed, for your help in solving this problem for me.

    • Proposed as answer by David Wang_Moderator Tuesday, April 5, 2016 6:58 AM
    • Marked as answer by Coobes Tuesday, April 5, 2016 7:02 AM
    Tuesday, April 5, 2016 6:03 AM

All replies

  • Where are you sending this message?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Monday, April 4, 2016 5:28 PM
    Moderator
  • I am looking for help to solve a problem I am having with message size limits.
    Monday, April 4, 2016 11:42 PM
  • And I am asking you a question about the problem you are facing.

    Where are you sending this "oversize" message?  Internally or to someone on the Internet.  Are you sure that this message isn't coming from the recipient's server?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Monday, April 4, 2016 11:54 PM
    Moderator
  • The receive connector limit would apply only to inbound mail.  From your description it appears you're sending mail.  Have you checked the send connector MaxMesageSize limit?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Monday, April 4, 2016 11:55 PM
    Moderator
  • I am sending an email from external with an attachment of 15MB to a mailbox inside the organisation. It appears in the NDR that the server not accepting the message is the destination server (not the sender's server).
    Tuesday, April 5, 2016 1:04 AM
  • Yes, it is an inbound mail message that is being rejected. No, I am sending from an external mail account into a mailbox in this exchange server and it is being rejected due to the size limits.

    I have checked and can only see the one receive connector and no smart hosts appear to be configured.

    Tuesday, April 5, 2016 1:06 AM
  • Receive connectors don't have smart hosts.  Do you have an antispam service, server or appliance between the Internet and your Exchange server?  Do you have an Edge Transport server?  You have just Exchange 2010, right, the mailbox isn't on Exchange 2003, is it?

    How many servers do you have and are they in different sites?

    Get-ADSiteLink | FL Name,MaxMessageSize

    Just to double-check:

    Get-TransportConfig | FL MaxSendSize,MaxReceiveSize
    Get-ReceiveConnector | FL Identity,MaxMessageSize
    Get-Mailbox -Identity <Recipient Name> | FL Name,MaxSendSize,MaxReceiveSize


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    • Marked as answer by Coobes Tuesday, April 5, 2016 6:01 AM
    Tuesday, April 5, 2016 5:10 AM
    Moderator
  • Hi,

    In general,the email size restriction for user mailbox will be applied in the following order:

    Global Transport configuration settings

    Receive connector size restriction

    In the user mailbox properties of send and receive size limit

    Please double check the above settings.

    Also have a look at the following article:

    http://eightwone.com/2010/09/29/exchange-message-size-limits/

    Please note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    David 



    Tuesday, April 5, 2016 5:17 AM
    Moderator
  • He's experiencing the problem with inbound mail so Send Connectors don't apply.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, April 5, 2016 5:22 AM
    Moderator
  • No Anti-Spam service, server or appliance between the Internet and the Exchange Server.

    It is an SBS2011 with Exchange 2010 and no other servers on the network.

    Get-ADSiteLink | FL Name,MaxMessageSize:

    Name           : DEFAULTIPSITELINK
    MaxMessageSize : unlimited

    Get-TransportConfig | FL MaxSendSize,MaxReceiveSize:

    MaxSendSize    : 40 MB (41,943,040 bytes)
    MaxReceiveSize : 40 MB (41,943,040 bytes)

    Get-ReceiveConnector | FL Identity,MaxMessageSize: (Actual Server Identity has ben changed to SERVER for privacy)

    Identity       : SERVER\Default SERVER
    MaxMessageSize : 40 MB (41,943,040 bytes)
    Identity       : SERVER\Windows SBS Fax Sharepoint Receive SERVER
    MaxMessageSize : 10 MB (10,485,760 bytes)
    Identity       : SERVER\Windows SBS Internet Receive SERVER
    MaxMessageSize : 10 MB (10,485,760 bytes)

    Is it one or both of these Identities that are the bottleneck for the message size limit?

    Get-Mailbox -Identity <Recipient Name> | FL Name,MaxSendSize,MaxReceiveSize: (Actual Mailbox Name has been changed to Mailbox Name for privacy)

    Name           : Mailbox Name
    MaxSendSize    : 40 MB (41,943,040 bytes)
    MaxReceiveSize : 40 MB (41,943,040 bytes)

    It looks like it could be either or both of the identities still set to 10MB limits that are the problem.

    • Marked as answer by Coobes Tuesday, April 5, 2016 6:01 AM
    • Unmarked as answer by Coobes Tuesday, April 5, 2016 7:02 AM
    Tuesday, April 5, 2016 5:29 AM
  • I changed the Identity :SERVER\Windows SBS Internet Receive SERVER (receive connector) limit from 10MB to 40MB and it solved the problem.

    I had clearly overlooked this identity when setting the size limit on my receive connectors.

    Thanks Ed, for your help in solving this problem for me.

    • Proposed as answer by David Wang_Moderator Tuesday, April 5, 2016 6:58 AM
    • Marked as answer by Coobes Tuesday, April 5, 2016 7:02 AM
    Tuesday, April 5, 2016 6:03 AM
  • You're welcome.  Happy to have helped.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, April 5, 2016 7:07 AM
    Moderator