none
Find Group in Active Directory throws an unexpected error. RRS feed

  • Question

  • All,

    I've begun to use the Project Server to TFS 2010 Integration and am having a problem with getting the Active Directory group to synchronize.

    I follow the instructions in this link:

    http://technet.microsoft.com/en-us/library/gg750243.aspx

    I'm able to get the screen to enter the Active Directory group I want to sync with the Project Server groups, but  then I get the dreaded:

    Error

    An unexpected error has occurred.

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 5af9c58e-114c-4206-a4e0-a569a5b38250

    In the logs, I found this information and exception.


    System.IndexOutOfRangeException: Cannot find table 0.     at System.Data.DataTableCollection.get_Item(Int32 index)     at Microsoft.Office.Project.PWA.ApplicationPages.ADFindGroupPage.FindGroup(Object sender, ImageClickEventArgs e)     at System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e)     at System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument)     at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    The Farm service account has read access to the AD groups and has full control of the Farm.

    However, the User Profile Service is currently turned off because of problems I've had with getting to work... not sure if one has anything to do with the other, but I want to put this detail in the post.

    Can anyone offer some advice on how to get past the error and get AD synchronize to work?

    Thank you for the time.

    Ron

    Monday, March 5, 2012 6:32 PM

All replies

  • Ron,

    one question, who are you logged in as when performing this action?

    I believe the currently logged in user's credentials are used (and stored) along with the AD sync settings.  Could that be the problem?

    I would try this same task when logged into PWA as the Install or other setup user account that created PWA in the first place.

    let us know.


    Thanks, Eric S. http://www.pcubed.com

    Monday, March 19, 2012 12:18 AM