locked
Windows 8 IE 10 Cannot open any SSL Intranet sites with Untrusted SSL certs RRS feed

  • Question

  • I have already seen this thread http://social.technet.microsoft.com/Forums/en-US/w8itprogeneral/thread/2719388a-840a-492c-a509-42804860ee9a/ and it do not solve the issue.  I ran the command and rebooted and it didn't solve the issue.

    We are using web pages on our local intranet and cannot get into them.  There is not even an option to import the certificate.  This is crazy that it doesn't even let us open sites on our local internal Intranet.

    The link to "Continue to this website (not recommended). " doesn't work because the link points to res://ieframe.dll/

    Windws 8 and IE 10.  

    Doe anyone have anything else to try besides the commands in the link above?

    Message says "There is a problem with this website's security certificate "  


    The security certificate presented by this website has errors, and should not be trusted. 
    Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.  
    Tuesday, April 9, 2013 5:26 PM

All replies

  • Hi,


    Have you checked other versions of Internet Explorer to test the issue?

    If it not work, please check the certificate and the website.

    If it works, please add the site the trusted sites and use the compatibility mode to check how it works.


    Also, rest the IE for test.


        1. Open Internet Explorer.

        2. Press “Alt key + X” from keyboard and select “Internet Options”.

        3. Select “Advanced” tab and then select “Reset” under “Reset Internet Explorer Settings”.


    Note
    : The Reset Internet Explorer Settings feature might reset security settings or privacy settings that you added to the list of Trusted Sites. The Reset Internet Explorer Settings feature might also reset parental control settings. We recommend that you note these sites before you use the Reset Internet Explorer Settings feature.


    Regards,


    Vincent Wang
    TechNet Community Support

    Thursday, April 11, 2013 3:23 AM
  • These are sites a few people in our group use daily and they are on our local intranet.  They are not external sites.  They are not sites for public use, so we did not pay for a external cert and we did not even create a GPO to automatically import these certs across the domain because only a few people use these sites and they can easily just import them into their local trusted CA.  We should not need to add local intranet sites the trusted zone since they are already in the local intranet zone.

    I have already tried resetting IE settings.

    I had been using Windows 7 an and XP with IE8 and either imported the certificate or just clicked past the warning to get into the site.  After getting a PC with Windows 8 and IE 10, I can no longer get into the site because it doesn't give any option to import the certificate as trusted CA locally or to ignore the warning and proceed past it.

    For some reason IE 10 keeps defaulting to ultra high security settings that is making it very difficult to live with.  I am also getting warnings about going into SSL sites and leaving SSL sites despite clicking the box that says don't show the message again.

    The Internet Zone security level gets set to High which turns off javascript and make it pretty much unusable for most websites (can't download anything, Flash doesn't load etc.).  I can reset it to default to access what I need, but later it reverts back to high again.

    I think this issue with not being able to get into a self-signed SSL cert site is probably related to the other overly restrictive security settings that keep applying.  We do not have any IE 10 specific group policies that should lock it down more than the IE 8 browsers that we use on other computers.  To get work done, I have had to install Chrome and Firefox so I can open these SSL sites because access to these sites are required to do our jobs.


    • Edited by MyGposts Thursday, April 11, 2013 3:49 AM
    Thursday, April 11, 2013 3:46 AM