none
Sharepoint Document Class Add on Missing in IE Microsoft InfoPath 2010 is required to use this feature." RRS feed

  • Question

  • I came up with an issue trying to use SharePoint designer and InfoPath from a custom list.  My problem was I could open SharePoint designer or InfoPath.  Every time I tried to open SPD, it will send me to the download because of the add on missing (hence I already had SPD installed on my machine.) the same was with InfoPath. I was getting an error "Microsoft InfoPath 2010 is required to use this feature." I researched the internet and everyone recommended to enable the SharePoint Document Class Add on Missing in IE within IE add-on. my problem was SharePoint Document Class Add on was missing from the IE add-ons list. Other blogs recommended to install SharePoint foundation which never heard of installing SharePoint foundation on a user computer.  One site recommended to uninstall/install outlook. This ringed the bell and let me to do a repair on my office suite. After doing a repair I was able to open SPD and InfoPath. Hope this helps someone out there.
    • Edited by Jsanz Monday, July 17, 2017 12:49 PM
    Monday, July 17, 2017 12:48 PM

Answers

  • FYI,

    My issue was fixed by repairing office suite on add/remove programs.


    • Marked as answer by Jsanz Wednesday, July 19, 2017 2:24 PM
    • Edited by Jsanz Wednesday, July 19, 2017 2:24 PM edit
    Wednesday, July 19, 2017 2:24 PM

All replies

  • Hi,

    I would guess that you don't have a version of MS Office or SharePoint Designer installed that includes the necessary IE Addon. "Microsoft InfoPath 2010". Try running a full Windows Update to update all of your MS Software.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Tuesday, July 18, 2017 9:25 PM
  • FYI,

    My issue was fixed by repairing office suite on add/remove programs.


    • Marked as answer by Jsanz Wednesday, July 19, 2017 2:24 PM
    • Edited by Jsanz Wednesday, July 19, 2017 2:24 PM edit
    Wednesday, July 19, 2017 2:24 PM