none
Windows 7 anonymous share Access

    Question

  • Hi,

    I've setup an anonymous access to a share on a Windows 2008 domain member server for workgroup clients to access.

    Windows XP clients are able to connect to the share OK without being prompted for credentials

    Windows 7 clients however get prompted for credentials when they connect to the share.

    How can I get Windows 7 clients to connect without being prompted for credentials ?

    The share will be used by Lenovo laptops to pull system updates via a system update application.

     

    Thanks

    Thursday, September 15, 2011 1:23 PM

Answers

  • This can be due to improper authentication. Configure the settings below on the Windows 7 clients:

    • Open regedit
    • Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    • Create a new DWORD value with the following properties attributes - NAME: LmCompatibilityLevel and VALUE: 1
    • Restart the PCs and try to connect now

    Please revert back here if this does not resolve your issue. Hope it helps!


    Kunal D Mehta - a Windows Server Enthusiast | My first TechNet Wiki Article
    • Edited by Server Baba Sunday, September 18, 2011 11:13 AM
    • Proposed as answer by zhen tan Tuesday, September 20, 2011 5:56 AM
    • Marked as answer by Robinson Zhang Thursday, October 06, 2011 4:30 PM
    Sunday, September 18, 2011 11:12 AM